Download it now!
Bug 109256 - SVG written by Matplotlib is not displayed correctly
Summary: SVG written by Matplotlib is not displayed correctly
Status: RESOLVED DUPLICATE of bug 100135
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2017-07-21 11:02 UTC by petr_aleksandrov
Modified: 2017-07-24 14:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample SVG file (23.29 KB, image/svg+xml)
2017-07-21 11:03 UTC, petr_aleksandrov
Details
Screenshot of Libreoffice with incorrectly displayed image (19.04 KB, image/png)
2017-07-21 11:03 UTC, petr_aleksandrov
Details
Screenshot of Chromium with the same SVG image (15.26 KB, image/png)
2017-07-21 11:03 UTC, petr_aleksandrov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description petr_aleksandrov 2017-07-21 11:02:41 UTC
Description:
SVG is not displayed correctly. See the screenshot. The SVG file is attached. This SVG is created by Matplotlib (matplotlib.org). The SVG is displayed correctly in Chromium browser.

Steps to Reproduce:
1. Insert the SVG image into a document.

Actual Results:  
The fragment of the horizontal line appears outside the frame.

Expected Results:
Whole horizontal line lies inside the frame.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/59.0.3071.109 Chrome/59.0.3071.109 Safari/537.36
Comment 1 petr_aleksandrov 2017-07-21 11:03:03 UTC
Created attachment 134762 [details]
Sample SVG file
Comment 2 petr_aleksandrov 2017-07-21 11:03:33 UTC
Created attachment 134763 [details]
Screenshot of Libreoffice with incorrectly displayed image
Comment 3 petr_aleksandrov 2017-07-21 11:03:59 UTC
Created attachment 134764 [details]
Screenshot of Chromium with the same SVG image
Comment 4 Alex Thurgood 2017-07-21 13:03:04 UTC
The image also shows correctly when loaded in Firefox.

Confirming with

Version: 5.3.4.2
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; Layout Engine: new; 
Locale: en-GB (fr_FR.UTF-8); Calc: group
Comment 5 V Stuart Foote 2017-07-21 18:41:37 UTC

*** This bug has been marked as a duplicate of bug 100135 ***