Download it now!
Bug 109260 - Double-lined text shifted not same value as normal text
Summary: Double-lined text shifted not same value as normal text
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: text:cjk, text:rtl
Depends on:
Blocks: CJK Vertical-Text
  Show dependency treegraph
 
Reported: 2017-07-21 17:23 UTC by kong
Modified: 2017-10-27 13:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
What's difference of the problem between this issue and others. (26.17 KB, image/png)
2017-07-21 17:23 UTC, kong
Details
Test Document (10.10 KB, application/vnd.oasis.opendocument.text)
2017-07-21 17:32 UTC, kong
Details
horizontal . no problem. (27.29 KB, image/png)
2017-07-21 17:36 UTC, kong
Details
vertical . shifted , and different style (double-lined and normal) different shifting. (20.44 KB, image/png)
2017-07-21 17:37 UTC, kong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kong 2017-07-21 17:23:27 UTC
Created attachment 134769 [details]
What's difference of the problem between this issue and others.

That's two issue . 
one is text shifted ( but same way , same verctor value ) , that was talked about in #101679. when i checked the #106045 , i also found #105178 and #105650 appear in 5.3.4.2 version on Fedora 26.
the other one is some text not shifted the same way.Double-lined text don't shift , but normal text shifted.

So i asked a question here : https://ask.libreoffice.org/en/question/112394/writerhow-to-fix-wrong-characters-position-in-vertical-text-direction/ :

Everything is perfect in horizontal text direction . If change to vertical text direction ( Format -> Page -> Page -> Text direction -> Right-to-left (vertical) ) , the asian characters are floating out the right place.Read the following two images , the asian text content with ( paragraph ) black border is never changed , just only set the text direction from horizontal to vertical.


--
Version: 5.3.4.2
Build ID: 5.3.4.2-3.fc26
CPU Threads: 2; OS Version: Linux 4.11; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: en-GB (en_GB.utf8); Calc: group
Comment 1 kong 2017-07-21 17:28:12 UTC
The system i selected is Linux because @gabix , in the Ask system , said Windows is no problem. I'm just only using Linux.
Comment 2 kong 2017-07-21 17:32:51 UTC
Created attachment 134770 [details]
Test Document
Comment 3 kong 2017-07-21 17:36:06 UTC
Created attachment 134771 [details]
horizontal . no problem.
Comment 4 kong 2017-07-21 17:37:28 UTC
Created attachment 134772 [details]
vertical . shifted , and different style (double-lined and normal) different shifting.
Comment 5 kong 2017-07-22 03:34:06 UTC
I checked and confirmed again that 5.3.3.2 on Windows is no problem at all.Just only just only happens on linux.

Is difference between directX and others about /canvas/source ?
Comment 6 Buovjaga 2017-07-22 15:25:45 UTC
I confirm in 5.3.4, but with master it works. So please try with 5.4 release candidates.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 7a7cba91a60c1c6d6645dfb8c7e88c5c6318ddee
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on July 21st 2017

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.4.2
Build ID: 5.3.4-1
CPU Threads: 8; OS Version: Linux 4.11; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 7 Dieter Praas 2017-09-10 21:08:20 UTC
Set to NEEDINFO, regarding to comment 6.
Comment 8 Mark Hung 2017-10-27 13:51:16 UTC
Hi,

Double line text shifted in vertical right to left layout. 
Steps to reproduce:
1. open the attachment #134770 [details]
2. Edit page style and change text direction to vertical right to left.
Actual Result: Text shifted ( both normal text and double-lined text ). Two narrower lines are not spread evenly.
Expected Result: They should occupy 50% of the line space.

版本:5.3.1.2
組建 ID:1:5.3.1-0ubuntu2
CPU 執行緒:4; OS 版本:Linux 4.10; UI 算繪:預設; VCL:gtk3; 文字排版引擎:新式; 
語言地區:zh-TW (zh_TW.UTF-8); Calc: group


Text-shifting in vertical layout is abnormal. I believe that this issue and the shifting in the vertical layout have the same root cause. However, it doesn't make sense to compare one incorrect result with another. So I do not think you should take "they don't have the same offset" as a bug.