Download it now!
Bug 109263 - Pastes incorrect content when copied content contains link while EDITING
Summary: Pastes incorrect content when copied content contains link while EDITING
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cut-Copy
  Show dependency treegraph
 
Reported: 2017-07-21 19:19 UTC by Kenny Kruger
Modified: 2017-07-24 14:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example test case of copy/paste issue (10.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-07-21 19:25 UTC, Kenny Kruger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenny Kruger 2017-07-21 19:19:45 UTC
Description:
I have a spreadsheet which contains cells that have links to external files. The cell would contain text and the link. If you select the cell and copy it, it will paste correctly. However, if you 'enter' a cell and select just the content you want to copy (text + link), then enter a new cell to paste the content -- the link will be missing, but the text pasted.

Steps to Reproduce:
1. Edit cell contents, adding the following content.
   "Words -> <link>"
   Where words are normal text along with the -> arrow
   Where <link> is short text and links to a file to open
2. Edit difference cell's contents, pasting the clipboard
3. Notice the pasted content is only, "Words ->" -- no link or link text

Actual Results:  
Pasted content was, "Words ->"

Expected Results:
Pasted content to be, "Words -> <link>"


Reproducible: Always

User Profile Reset: No

Additional Info:
I am able to reproduce the issue on other computers (same OS and architecture, different user profiles)


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Comment 1 Kenny Kruger 2017-07-21 19:25:50 UTC
Created attachment 134776 [details]
Example test case of copy/paste issue
Comment 2 m.a.riosv 2017-07-22 11:23:15 UTC
Works for me on:
Version: 6.0.0.0.alpha0+
Build ID: 403ddd6cb1c0d6a0e0db105e68f58fe40057cb42
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-14_23:37:46
Locale: es-ES (es_ES); Calc: group
http://dev-builds.libreoffice.org/daily/master/

On Version: 5.4.0.2 (x64) doesn't work so at some point it was solved.