Bug Hunting Session
Bug 109271 - Assert when closing Index or bibliography entry dialog (debug only)
Summary: Assert when closing Index or bibliography entry dialog (debug only)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:6.0.0
Keywords: haveBacktrace
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2017-07-22 11:47 UTC by Julien Nabet
Modified: 2017-07-24 14:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (5.25 KB, text/plain)
2017-07-22 11:48 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2017-07-22 11:47:57 UTC
Description:
On pc Debian x86-64 with master sources updated yesterday + enable-dbgutil, I got an assert when closing index entry or bibliography entry dialog

Steps to Reproduce:
1. Open Writer with no specific files
2. Menu Insert, "Table of Contents and Index", "Index Entry..."
=> a dialog appears
3. Close dialog (with "Close" button)

Actual Results:  
Assert:
soffice.bin: /home/julien/lo/libreoffice/include/vcl/vclptr.hxx :116 : VclPtr<T>::~VclPtr() [with reference_type = AbstractMarkFloatDlg]:  l'assertion « (!m_rInnerRef.get() || m_rInnerRef->isDisposed() || m_rInnerRef->getRefCount() > 1) && "someone forgot to call dispose()" » failed.


Expected Results:
no assert


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Julien Nabet 2017-07-22 11:48:41 UTC
Created attachment 134781 [details]
bt with debug symbols
Comment 2 Xisco Faulí 2017-07-22 12:02:12 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: e0b6a4a2d2dec4e9614f27fc03f84b1c578028ec
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

nor gtk3

nor

Version: 6.0.0.0.alpha0+
Build ID: a9588baca8137f51e2ca72e40b1f448b0e1885d1
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-07-21_03:03:23
Locale: es-ES (es_ES); Calc: group

debug only ?
Comment 3 Julien Nabet 2017-07-22 12:09:04 UTC
Xi(In reply to Xisco Faulí from comment #2)
> ...
> debug only ?

Yes debug only since assert. I'll put this on title
Comment 4 Julien Nabet 2017-07-22 12:22:31 UTC
Let's give a try with https://gerrit.libreoffice.org/#/c/40306/
Comment 5 Commit Notification 2017-07-22 13:51:13 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dc86ea81ae26b972c52448ee367c9ea5d8d92b4

tdf#109271: Use ScopedVclPtr

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Julien Nabet 2017-07-22 19:38:29 UTC
(In reply to Julien Nabet from comment #6)
> 5.4: https://gerrit.libreoffice.org/#/c/40312/1
Abandoned.
See gerrit comments.