Bug 109290 - Tooltip with page number in Slides pane is superfluous/annoying
Summary: Tooltip with page number in Slides pane is superfluous/annoying
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Slide-Page-Pane
  Show dependency treegraph
 
Reported: 2017-07-23 20:41 UTC by Federico Mena-Quintero
Modified: 2017-07-27 20:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Mena-Quintero 2017-07-23 20:41:36 UTC
The Slides pane, which displays thumbnails of each page in the presentation, looks like

  1 +------+
    |      |
    +------+
  2 +------+
    |      |
    +------+
  3 +------+
    |      |
    +------+

That is, each thumbnail has the slide number on the left.

When you mouseover each slide, LO prelights each thumbnail *and* also displays a tooltip with the slide number.  This tooltip is redundant and rather annoying. Since the slide has its slide number on the left, the tooltip should not appear at all.
Comment 1 Federico Mena-Quintero 2017-07-24 17:16:46 UTC
Removing the "Blocks" for bug #48799 - this is *not* about bullets and numbering; it's about the slide thumbnails pane.
Comment 2 Yousuf Philips (jay) (retired) 2017-07-26 17:54:38 UTC
The tooltip is of the slide name if it is assigned, so there is some benefit of the tooltip, so WONTFIX for me.

Heiko, Cor, Stuart: What's your take?
Comment 3 V Stuart Foote 2017-07-26 18:19:51 UTC
Right, when the slide has been assigned a title the tooltip--and Navigator--will show that, rather than the generic sequentialy numbered slide name. 

It also is part of our a11y support to expose the Tooltip to Assistive Technology tools as the object description. So this is a WONTFIX.

@Jay, on a sidebar--did we have an open issue for treating slides as objects and formatting Name/Alt-Text for them? Would that be part of the bug 96355 work for an object properties dialog? As is now, setting title is limited to Slide -> Rename Slide or the Slides pane context menu Rename Slide. 

Slides need to have titles/names at least, but alternate text descriptions is a requirement for a11y. Currently the Rename Slide is not present on the slide context menu, nor its Slide Properties dialog.
Comment 4 Yousuf Philips (jay) (retired) 2017-07-27 20:16:27 UTC
(In reply to V Stuart Foote from comment #3)
> @Jay, on a sidebar--did we have an open issue for treating slides as objects
> and formatting Name/Alt-Text for them?

Not that i'm aware of.

> Would that be part of the bug 96355 work for an object properties dialog?

No slides wouldn't be part of the all-in-one object properties dialog.

> As is now, setting title is limited to
> Slide -> Rename Slide or the Slides pane context menu Rename Slide. 

We do have Slide > Slide Properties where the naming of a slide can also go if it needs to be in another location (bug 109528).

> Slides need to have titles/names at least, but alternate text descriptions
> is a requirement for a11y. Currently the Rename Slide is not present on the
> slide context menu, nor its Slide Properties dialog.

Do note that OOXML doesnt support titles/names, so this would only be applicable to ODF. If ODF supports alt-text on slides, then it should be accessible somewhere, like the slide properties dialog, so possibly check the spec yourself or reach out to Regina.