Bug 109315 - CPU spikes when in options dialog paths section (gtk3)
Summary: CPU spikes when in options dialog paths section (gtk3)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: GTK3 Options-Dialog-Paths CPU-AT-100%
  Show dependency treegraph
 
Reported: 2017-07-24 16:22 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-11-03 21:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (29.26 KB, text/x-log)
2017-09-18 18:43 UTC, Yousuf Philips (jay) (retired)
Details
my backtrace (68.91 KB, text/x-log)
2017-09-19 05:54 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-07-24 16:22:16 UTC
Steps:
1. Open Writer
2. Tools > Options > LibreOffice > Paths
3. One cpu core spikes to 100%
4. Select LibreOffice > Font and cpu core returns to normal
5. Select LibreOffice > Paths and cpu is still fine
6. Select AutoCorrect entry and double-click or click 'Edit' button
7. One cpu core spikes to 100%

Version: 6.0.0.0.alpha0+
Build ID: 888f3f18cf42ca08f55a5e4826b4298f391e14aa
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

This doesnt happen when running the same version in gtk2.
Comment 1 Aron Budea 2017-07-24 19:08:12 UTC
Can't reproduce with the following build. Checked using htop, no cores had more than 10% utilization.

Version: 6.0.0.0.alpha0+
Build ID: 4815b6f7c70cca5a226163caaaab8a227f32be48
CPU threads: 16; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-GB (en_US.UTF-8); Calc: group
Comment 2 Caolán McNamara 2017-07-25 12:12:02 UTC
I don't see it either
Comment 3 Yousuf Philips (jay) (retired) 2017-07-25 18:56:27 UTC
The version i tested in the description is moggi's daily updater build on my Linux Mint 18 desktop. I just tested a git build on my laptop which i did some time ago on Ubuntu Mate 16.04 and it shows the same issue.

Possibly this issue only shows with the gtk 3.18.9 which is available in Ubuntu 16.04 LTS.

Version: 6.0.0.0.alpha0+
Build ID: 6580e171ad054dca38f55822e67a400191cecdf5
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 Caolán McNamara 2017-08-19 13:48:32 UTC
Is this perhaps a duplicate of bug #108246 ? i.e. what's the version of glib2 ?

https://git.gnome.org/browse/glib/commit/?id=9ba95e25b74adf8d62effeaf6567074ac932811c
Comment 5 Yousuf Philips (jay) (retired) 2017-08-21 10:22:15 UTC
(In reply to Caolán McNamara from comment #4)
> Is this perhaps a duplicate of bug #108246 ? i.e. what's the version of
> glib2 ?

Not sure if its a duplicate. glib2.0-0 is version 2.48.2.
Comment 6 Yousuf Philips (jay) (retired) 2017-09-18 12:53:15 UTC
Still happens on today's build - 2017-09-18_00.33.41

Version: 6.0.0.0.alpha0+
Build ID: dd5868409ae430f9c9ffea18ea7e287a65cfa2ab
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 Jean-Baptiste Faure 2017-09-18 14:17:29 UTC
Reproducible for me with Version: 6.0.0.0.alpha0+
Build ID: 69e62bbebc1f4809101df0c694a930b07dbc194d
Threads CPU : 4; OS : Linux 4.4; UI Render : par défaut; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: single

built today at home under Ubuntu 16.04 x86-64

Set to NEW.
Best regards. JBF
Comment 8 Caolán McNamara 2017-09-18 14:51:14 UTC
run it under gdb and ctrl+c when its busy and get a bt, cont to continue, ctrl+c again, and repeat a few times sampling what the bt is and see if its typically the same bt and if so then paste that here ?
Comment 9 Xisco Faulí 2017-09-18 17:59:47 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: dd5868409ae430f9c9ffea18ea7e287a65cfa2ab
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Ubuntu 17.04
Comment 10 Yousuf Philips (jay) (retired) 2017-09-18 18:43:16 UTC
Created attachment 136346 [details]
backtrace

(In reply to Caolán McNamara from comment #8)
> run it under gdb and ctrl+c when its busy and get a bt, cont to continue,
> ctrl+c again, and repeat a few times sampling what the bt is and see if its
> typically the same bt and if so then paste that here ?

pressed ctrl+c in the terminal window when it was busy, but that closed LO and exited gdb, so not sure how to repeat 'cont to continue, ctrl+c again'. so then repeated the steps in comment 0 in gdb and attached in the log.
Comment 11 Jean-Baptiste Faure 2017-09-18 18:51:32 UTC
(In reply to Caolán McNamara from comment #8)
> run it under gdb and ctrl+c when its busy and get a bt, cont to continue,
> ctrl+c again, and repeat a few times sampling what the bt is and see if its
> typically the same bt and if so then paste that here ?

Will try to get a backtrace but before I need to rebuild in debug mode.

Some observations: it seems that cpu is busy in options dialogs with "add" button. For example in the dialog Macro Security, the first tab Security Level does not consume more than 10% of one cpu while the second tab Trusted Source consumes almost one cpu (> 70%).
Other affected options dialogs: each "Edit Path" dialog, Certificate Path,

Expert configuration dialog is affected too but it as an Edit button, not an Add button.

But not:
- "Time Stamping Authority URLs" dialog
- Advanced dialog

Best regards. JBF
Comment 12 Xisco Faulí 2017-09-18 19:00:13 UTC
@JBF, you can also use a debug daily build...
Comment 13 Jean-Baptiste Faure 2017-09-19 05:54:02 UTC
Created attachment 136358 [details]
my backtrace

Here is the log of my gdb session with several backtrace. Hope this helps. I can do more tests if needed.

Version: 6.0.0.0.alpha0+
Build ID: 9d837f19d1bf4cfbdee528e027f5b72d9b1da73d
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale: fr-FR (fr_FR.UTF-8); Calc: single

Best regards. JBF
Comment 14 QA Administrators 2018-10-30 03:56:28 UTC Comment hidden (obsolete)
Comment 15 Jean-Baptiste Faure 2018-11-03 21:52:28 UTC
Not reproducible for me with versions 6.1.x and current master, both built at home under Ubuntu 18.04 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF