Bug 109327 - LO Crashes upon interacting with Zotero plugin on 32-bit systems
Summary: LO Crashes upon interacting with Zotero plugin on 32-bit systems
Status: RESOLVED DUPLICATE of bug 108619
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-25 02:10 UTC by Tom Colley
Modified: 2017-07-28 11:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Colley 2017-07-25 02:10:56 UTC
Description:
I have been using LO 5.x  with Zotero 4.x bibliographic software (running in Firefox) for some time without any major issues. I recently upgraded to Zotero 5.06. Zotero 5.06 (which runs independently of Firefox) functions well on its own, but (for me) fails to integrate with LO: LO crashes when any Zotero functions are initiated from the Zotero toolbar in LO. Others and I have pursued the matter with Zotero developers:
SEE https://forums.zotero.org/discussion/66569/libreoffice-crashes-when-clicking-on-insert-citation
AND https://forums.zotero.org/discussion/66609/libreoffice-v5-crashes-when-used-with-zotero-v5?new=1

The integration of LO and Zotero is done by a plugin for which I have tried old and new versions (3.5.9 and 5.0.4). LO crashes with both versions of the plugin. 
After much investigation, Zotero development team suggest that the problem is likely to be a LO library as reports of this problem come from multiple people with different versions of Linux.

I notice that Bug 105705 describes a similar problem but with Zotero 4.x (in Firefox).

----------My System-----------
OS: Ubuntu 14.04 32bit
Libreoffice Version: 5.3.4.2
Zotero Version: 5.06
-------------------------------

Steps to Reproduce:
1. Install Libreoffice Version: 5.3.4.2 and Zotero Version: 5.04 on Ubuntu 14.04 32bit
2. Install the LO plugin for Zotero (remove any old Zotero plugin in LibreOffice -> Tools -> Extension Manager, close LO, install the new plugin from Zotero application by going to Preferences -> Cite -> Word Processor Plugins)
3. Open LO with a new document and then click any of the buttons on the Zotero toolbar (e.g. Add Citation or Set Document Preferences)

Actual Results:  
LO crashes

Expected Results:
LO inserts a Zotero citation into the document or allows Zotero document preferences to be set.


Reproducible: Always

User Profile Reset: Yes, I initiated a new user profile (by renaming the current one) several times while investigating this problem - see Zotero discussion thread mentioned above.

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Buovjaga 2017-07-25 06:32:05 UTC
Is there a reason you are using a 32-bit Ubuntu (ie. your CPU only supports 32-bit)? Unfortunately there are no 32-bit debug builds currently available, so you cannot try getting a backtrace of the crash.
Comment 2 Adomas Venčkauskas 2017-07-25 06:58:25 UTC
Also note that this is unrelated to Bug 105705 . We have identified the reason for that crash as described in https://bugs.documentfoundation.org/show_bug.cgi?id=105705#c17

This, on the other hand is something else and occurs at a different part of the LibreOffice code. I could not reproduce it myself, but I did not know this is triggered on 32bit systems, which is worth investigating.
Comment 3 chiefmanyrabbitguteat 2017-07-25 19:55:21 UTC
My current installation also suffers from this bug. Like the OP, I am running 32 bit (Ubuntu Mate 16.04 in my case). I first noticed the bug on 32 bit Ubuntu Mate 17.04, and downgraded, after trying everything else, in order to make it stop. I had several days where Zotero/Libreoffice played nicely, but the issue started again last night when I clicked on "Edit Citation" in the Zotero toolbar. LibreOffice froze and then crashed, and now it crashes every single time I click any button in the Zotero toolbar.
Comment 4 chiefmanyrabbitguteat 2017-07-25 19:57:34 UTC
For what it's worth, in my case I am constrained to 32 bit because my laptop is a 32 bit Core Duo machine. My desktop -- a 64 bit machine is identical, and has not experienced any issues, but I don't think I've ever clicked on "edit citation" on it. Will try it this evening and respond with the results.
Comment 5 chiefmanyrabbitguteat 2017-07-25 19:59:07 UTC
**edit** I didn't click Edit citation. It was one of the other buttons... Refresh maybe?
Comment 6 Tom Colley 2017-07-26 04:58:24 UTC
(In reply to Buovjaga from comment #1)
> Is there a reason you are using a 32-bit Ubuntu (ie. your CPU only supports
> 32-bit)? Unfortunately there are no 32-bit debug builds currently available,
> so you cannot try getting a backtrace of the crash.

I started with 32-bit system on this laptop 6 years ago when 32-bit seemed more reliable and flexible. There is now significant customisation on this laptop that gets passed on during OS upgrades and I don't have many spare days for installing fresh OS's! 

There does seem to be a pattern emerging that Zotero users having this problem all have 32-bit systems. Mmmm
Comment 7 Julien Nabet 2017-07-26 16:06:09 UTC
On pc Debian x86-64 with master sources updated today, I tried to install Zotero plugin but don't succeed.

I install Zotero-standalone Debian package with apt
Then I tried "Edit, preferences, cite",
I only see in word processing tab a checkbox unchecked with label "use the classic window to add a quotation" (translation from French).

Then I searched "zotero" with apt-cache and I got:
xul-ext-lyz - connect zotero to lyx
libreoffice-zotero-integration - LibreOffice plugin to organize and share your research sources
xul-ext-zotero - Firefox extension to organize and share your research sources
zotero-standalone - organize and share your research sources

julien@debian:~/lo/libreoffice$ apt-cache show libreoffice-zotero-integration
Package: libreoffice-zotero-integration
Source: zotero-standalone-build
Version: 4.0.29.16+dfsg-1
Installed-Size: 344

I installed it but, as expected, I only see Zotero on LO Debian package, not on the LO I build from sources. So I'm a bit stuck to try some debug.
Comment 8 Julien Nabet 2017-07-26 16:14:54 UTC
Finally I copied the extension directory:
cp -R /usr/lib/libreoffice/share/extensions/Zotero_OpenOffice_Integration in <root of build>/instdir/share/extensions
and Zotero finally appears.
Comment 9 Julien Nabet 2017-07-26 16:18:20 UTC
and since I use x86-64, can't reproduce a bug specific to 32 bits...
Comment 10 Michael Stahl (allotropia) 2017-07-28 11:52:07 UTC
this is caused by Linux kernel Stack-Clash security fix breaking 32-bit x86 JVM.

workaround: downgrade kernel or use 64-bit LO & JVM.

*** This bug has been marked as a duplicate of bug 108619 ***