Download it now!
Bug 109525 - FILEOPEN: Microsoft font Segoe UI Light is not properly substituted in Linux so text may change position (Correct on Win)
Summary: FILEOPEN: Microsoft font Segoe UI Light is not properly substituted in Linux ...
Status: RESOLVED DUPLICATE of bug 64509
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2017-07-27 17:16 UTC by Xisco Faulí
Modified: 2018-12-25 18:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
comparison Linux and Windows (170.78 KB, image/png)
2017-07-27 17:16 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-07-27 17:16:11 UTC
Created attachment 134909 [details]
comparison Linux and Windows

Steps to reproduce:
1. Open attachment 90877 [details] from bug 72790
2. Check first page

Observed behaviour: 'Demo Guide' is displayed before the image. See attached image

Reproduced in 

Version: 5.4.0.3
Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 4.4.0.0.alpha0+
Build ID: f4246fab77113147b36706a1f3d93e8724ff826b
Comment 1 Buovjaga 2017-08-20 16:31:53 UTC
Confirmed.

The only difference I could think of was the fonts, but even if I changed them to something available on Linux, there was no effect to the image position.
Image is anchored To Character.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 668ab2e739397e6b095372a1a468bd4f515927b6
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 20th 2017

Win 10
Version: 6.0.0.0.alpha0+ (x64)
Build ID: b9f85538e65882238de80ab36c864bc0082ad7f4
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-08-20_01:44:43
Locale: fi-FI (fi_FI); Calc: group
Comment 2 QA Administrators 2018-08-21 02:34:51 UTC Comment hidden (obsolete)
Comment 3 Timur 2018-12-25 18:13:01 UTC
Repro 6.3+. 
But I think this is about fonts. 'Demo Guide' is "Segoe UI Light". 
Change to Arial Black, both are below. Change to Arial, both are above the image. 
Again we have Bug 61134 not to know what's it substituted for. I guess it should really be "Open Sans Light". 
I change the title to "Segoe UI Light is not properly substituted in Linux".
But I'll go further and set as duplicate of Bug 64509.

*** This bug has been marked as a duplicate of bug 64509 ***