Bug 109994 - Installation succeeds but subsequent execution fails with missing api-ms-win-crt-runtime-l1-1-0.dll
Summary: Installation succeeds but subsequent execution fails with missing api-ms-win-...
Status: RESOLVED DUPLICATE of bug 108580
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-29 01:13 UTC by Robert McClure
Modified: 2017-08-28 18:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert McClure 2017-07-29 01:13:22 UTC
Installation proceeds normally but execution fails because of missing component: api-ms-win-crt-runtime-l1-1-0.dll. Removed 5.4.0.3 and tried again with same result. Removed 5.4.0.3 and reinstalled 5.3.3 and it is fine.
Comment 1 Regina Henschel 2017-07-29 12:13:47 UTC
How do you install this version? Which version of Windows do you use? Do you have the right to save something into c:\Windows\ ?
Comment 2 Aron Budea 2017-07-29 15:22:43 UTC
According to this:
https://helpx.adobe.com/creative-cloud/kb/error_on_launch.html

The following update is missing:
Update for Universal C Runtime in Windows
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows
Comment 3 Aron Budea 2017-07-29 20:51:15 UTC
Robert, please reply here in the bug report. You mentioned that the runtime was installed in your Windows version, both 32-bit and 64-bit, or only one of them? Note that LibreOffice requires a runtime with the same bitness.
Comment 4 Robert McClure 2017-07-29 22:19:16 UTC
The missing module was in both the 32 bit and the 64 bit folders. I went to the trouble however, of downloading the update files from Microsoft again and this has now fixed the problem. I cannot see any difference in the api repositories on the machine. I suppose it is possible that it was some kind of permissions problem, but the prior version (5.3.3) never had any problems whatsoever.
Comment 5 Aron Budea 2017-07-29 22:43:04 UTC
Indeed, it's still a bit strange, could you share the Windows version you're using?
Comment 6 Robert McClure 2017-07-30 00:26:09 UTC
Operating system Windows 7 Ultimate, service pack 1, all important updates as of 10 Jun 2017.

processor AMD FX 6100 Six Core 3.3 GHz

memory 16.0 GB

C: is a SSD of 882 GB
other disks E:, F;, H; total 5.5 TB
Comment 7 Aron Budea 2017-08-10 20:31:19 UTC

*** This bug has been marked as a duplicate of bug 108580 ***