Bug 110003 - Lower-case ß is capitalized as SS instead of ẞ
Summary: Lower-case ß is capitalized as SS instead of ẞ
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
URL: http://www.unicode.org/L2/L2017/17224...
Whiteboard: target:7.3.0 target:7.2.4
Keywords:
: 113486 (view as bug list)
Depends on:
Blocks: Character
  Show dependency treegraph
 
Reported: 2017-07-29 13:33 UTC by Peter Wiegel
Modified: 2021-11-14 22:49 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Wiegel 2017-07-29 13:33:51 UTC
Description:
There are, since June 29. 2017 new rules in german orthography, where it is allowed now, that when a word with ß is capitalizes, the capital letter ẞ can be used, instead of the still possible replacement with SS.
This is a great advantage, when names, containing the letter ß are written in capital letters.

But until now, I only cab choose from "Format - Text" the change to "GROSSBUCHSTABEN" and get SS from ß.



Steps to Reproduce:
1. Write anything with the letter ß
2. go to "Format" - "Text" and click on "GROSSBUCHSTABEN"
3. the letter ß will be replaced by SS

Actual Results:  
I only have the choice to set the change from ß to SS when capitalize or set to small caps which also is missing there, and have to replace it by hand to ẞ when I want to use that letter instead

Expected Results:
I would suggest, to give a second choice:

"GROSSBUCHSTABEN"
and 
"GROẞBUCHSTABEN"
to choose from, or in language setting the choice between SS and capital ß, so that in the menu will be displayed GROSSBUCHSTABEN or GROẞBUCHSTABEN, whatever is set in the language-settings, maybe with a SS fallback, if ẞ doesn't exist in the font.


Reproducible: Always

User Profile Reset: No

Additional Info:
I also wanted to have the choice to switch to small caps, also with the choice of replacing ß by SS or capital ß in the same menu.


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Adolfo Jayme 2017-08-05 16:35:36 UTC
It is my humble UX opinion that we want to eventually just embrace the new standard instead of adding an option to switch between SS and ẞ. This is very low-level; I think this needs a change in ICU and Unicode itself.
Comment 2 Heiko Tietze 2017-08-07 07:51:57 UTC
Agree with Adolfo. Today the lower case ß is converted into SS when capitalized, and that is wrong now. The example with "Grossbuchstabe" is misleading because the word has to be written with eszett. Depending on the used font the uppercase character might not be implemented making the conversion still necessary.
Comment 3 Adolfo Jayme 2017-10-27 18:26:37 UTC
*** Bug 113486 has been marked as a duplicate of this bug. ***
Comment 4 Thomas Lendo 2017-11-01 19:31:55 UTC
I like the idea of a new section in the options dialog where the user can choose what should be done with ß: (1) ẞ, (2) SS (e.g. for better readability or habit or personal preference) and (3) SZ (for old Switzerland behavior).
Comment 5 Adolfo Jayme 2017-11-08 23:10:36 UTC
Thomas: as said above, we are not looking to add any options for users to switch between the two capitalizations; we want to embrace the new orthography and that’s it. A user who wants to use “SS” can just simply type it that way. And as Heiko says, we need an internal fallback to the old-style capitalization (as current Google Chrome has) just in case that the user is using a font lacking the character U+1E9E.
Comment 6 mafanie 2017-11-14 04:59:01 UTC
While I personally also would prefer to have "uppercase(ß) = ẞ", the new and old standard still seams to be "uppercase(ß) = SS", see the ISO standard [1], the Unicode standard [2] and the proposal that added ẞ to the ISO standard [3].
(This seems also to be the meaning of the "Rat für deutsche Rechtschreibung" which only allows the usage of ẞ, but does not prefer it over the old rule [4].)

But there is still a minor bug (according to the standards mentioned) related to ß/ẞ: Currently "lowercase(ẞ) = ẞ", which should be changed to "lowercase(ẞ) = ß".

[1] ISO/IEC 10646:2014 (E), page 59 and 245
[2] Unicode standard 10.0, http://www.unicode.org/versions/Unicode10.0.0/UnicodeStandard-10.0.pdf, page 276
[3] http://std.dkuug.dk/jtc1/sc2/wg2/docs/n3227.pdf, page 4
[4] http://www.rechtschreibrat.com/DOX/rfdr_PM_2017-06-29_Aktualisierung_Regelwerk.pdf, §25 E3
Comment 7 Stuart Ng 2018-01-26 22:59:48 UTC
Hello, is there any expected date as to when this issue might be fix? Or is there any work around?

Thanks,
Stuart
Comment 8 d-eberhdt64 2021-01-10 18:04:01 UTC
This bug also concerns formatting as 'small caps' (Kapitälchen) - if a proper name containing U+00DF ('ß' 'sharp s' 'Eszett') is formatted to small caps, the display of the 'Eszett' changes to double-S, while copy-and-paste shows that the character in the file is still 'Eszett'. For some proper names this will visibly falsify the spelling. (Which *is* an issue.) Simply downsizing an upper case 'Eszett' ẞ (U+1E9E) rather breaks the layout than being a solution. -- Reproduced in LibreOffice Writer 6.4.7.2 -- https://de.wikipedia.org/wiki/Gro%C3%9Fes_%C3%9F (Großes_ß) mentions that according the standard DIN 5008, updated 2020, upper case 'Eszett' is now preferred over 'SS' or 'SZ'. "Gemäß der 2020 erschienenen Fassung der DIN 5008 „Schreib- und Gestaltungsregeln für die Text- und Informationsverarbeitung“ gilt: „Bei der Verwendung von Großbuchstaben ist das große ẞ der Auflösung in SS bzw. SZ vorzuziehen“.[15] -- [15] https://de.wikipedia.org/wiki/DIN_5008 DIN 5008:2020-03, Abschnitt 13 „Hervorhebungen“, Fußnote 5 -- So now there is a reason to fix it.
Comment 9 d-eberhdt64 2021-01-10 18:08:33 UTC
(In reply to Stuart Ng from comment #7)
> Hello, is there any expected date as to when this issue might be fix? Or is
> there any work around?
> 
> Thanks,
> Stuart

The workaround for plain capitals is to enter an upper case 'sharp s' U+1E9E manually (check your keyboard's instruction, in some linuxes with German keyboard it's: activate capslock, then press 'ß'). Of course, depending on the font containing the glyph. D.
Comment 10 Commit Notification 2021-11-11 00:28:20 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/07a2afa4904ac51c9c61aaf41a9d6c7d41126531

Resolves: tdf#110003 tdf#143128 handle lowercase ß vs uppercase ẞ folding

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-11-11 14:30:35 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/b7c707223cb44f9423294295ac5d04cc1e2314a2

Resolves: tdf#110003 tdf#143128 handle lowercase ß vs uppercase ẞ folding

It will be available in 7.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.