Bug Hunting Session
Bug 110424 - FILESAVE: PPTX rotated shapes transposed on slide
Summary: FILESAVE: PPTX rotated shapes transposed on slide
Status: RESOLVED DUPLICATE of bug 91999
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-29 20:08 UTC by Luke
Modified: 2017-08-02 16:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Native Impress shape shifted (10.56 KB, application/vnd.oasis.opendocument.presentation)
2017-07-29 20:08 UTC, Luke
Details
Native PowerPoint also shifted on RT (28.81 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-07-29 20:08 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2017-07-29 20:08:22 UTC
Created attachment 134983 [details]
Native Impress shape shifted

Steps to reproduce:
1. In Impress draw a shape
2. Rotate the shape
3. Save as PPTX 
4. Open in Impress or PowerPoint

Note the position of the shape will be shifted
Comment 1 Luke 2017-07-29 20:08:50 UTC
Created attachment 134984 [details]
Native PowerPoint also shifted on RT
Comment 2 tommy27 2017-07-30 06:47:37 UTC
I confirm bug but I can tell that's not a new issue (did you check for potential duplicates?)

if I open  attachment 134983 [details] in LibO 5.2.5.1 and 5.3.4.2 and I save it as .PPTX I see the shift of the shape.

we should check if it ever worked in previous releases.

tested under Win8.1 x64
Comment 3 Luke 2017-07-31 17:16:20 UTC
Any rotation shifts shapes down in LibreOffice 3.3.4 OOO330m19 (Build:401). So if this is a regression, it likely goes back to OOo days.
Comment 4 Luke 2017-08-02 16:02:53 UTC

*** This bug has been marked as a duplicate of bug 91999 ***
Comment 5 tommy27 2017-08-02 16:54:46 UTC
cool... you made a duplicate report of a bug submitted by yourself years ago...
I remember I did the same one time  :-)