Bug 110448 - Remove "Memory" page from Options dialog; only adjust the settings using Expert Configuration
Summary: Remove "Memory" page from Options dialog; only adjust the settings using Expe...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on: 111083
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2017-07-31 06:58 UTC by Mike Kaganski
Modified: 2018-07-06 11:09 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2017-07-31 06:58:25 UTC
Options-LibreOffice-Memory page has some settings that control Image and OLE caches:
[Image Cache]
  Use for LibreOffice: X MB 190
  Memory per object: X MB 12
  Remove from memory after: XX:XX hh:mm 10
[Cache for Inserted Objects]
  Number of objects: N 20

Their corresponding settings are
/org.openoffice.Office.Common/Cache/GraphibManager/TotalCacheSize
/org.openoffice.Office.Common/Cache/GraphibManager/ObjectCacheSize
/org.openoffice.Office.Common/Cache/GraphibManager/ObjectReleaseTime
/org.openoffice.Office.Common/Cache/DrawingEngine/OLE_Objects
and this setting seems to depend on latter:
/org.openoffice.Office.Common/Cache/Writer/OLE_Objects

The settings control caches, i.e. how long do *unused* graphic objects stay in memory to speed up their reuse if need arises, and how much of them are kept. These settings don't control other memory-related aspects of LO; and they generally are unrelated to performance issues in LO. But it's common misconception among users that in case of performance problems in LO, this page settings needs to be tweaked to try to fix those problems. There are plenty of such advises in all user support forums.

My suggestion is to remove this settings page altogether, and only allow changing the settings using Expert Configuration dialog.
Comment 1 Tor Lillqvist 2017-07-31 07:02:13 UTC
I fully support this.
Comment 2 m.a.riosv 2017-08-01 11:26:19 UTC
But we must be sure 'Use for LibreOffice' it's updated when updating LibreOffice, old values under 48MB it's where the slowness is very visible. 

https://bugs.documentfoundation.org/show_bug.cgi?id=94760#c8
Comment 3 Mike Kaganski 2017-08-01 14:28:13 UTC
Last 3 commits that changed the limits:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=75c272c1 (the one mentioned in comment 2)
https://cgit.freedesktop.org/libreoffice/core/commit/?id=41de4df1
https://cgit.freedesktop.org/libreoffice/core/commit/?id=55baf61c

(In reply to m.a.riosv from comment #2)
> But we must be sure 'Use for LibreOffice' it's updated when updating

Does it now? The default values aren't stored in user profile (registrymodifications.xcu) until user changes any of them manually. It means that *unchanged* values are updated with each LO update that has new defaults. However, we cannot "update" user-defined values. The change is not going to change the way it is now.
Comment 4 m.a.riosv 2017-08-01 14:46:25 UTC
(In reply to Mike Kaganski from comment #3)
> Last 3 commits that changed the limits:
> Does it now? The default values aren't stored in user profile
> (registrymodifications.xcu) until user changes any of them manually. It
> means that *unchanged* values are updated with each LO update that has new
> defaults. However, we cannot "update" user-defined values. The change is not
> going to change the way it is now.

Thanks for the clarification.
I'm agree on remove them, if some one has changed it, I guess it was for a higher value.
Comment 5 Mike Kaganski 2017-08-01 15:18:27 UTC
A patch is in gerrit: https://gerrit.libreoffice.org/40640
Comment 6 Commit Notification 2017-08-02 08:39:23 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=765398294b872d01fba5345a7aa65f310ff27868

tdf#110448: Remove "Memory" page from Options dialog

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Oliver Brinzing 2017-08-05 14:18:21 UTC
On Windows the "Memory" Page contains the
[ ] Load LibreOffice during system start-up
option. What will happen with this setting?
Comment 8 Yousuf Philips (jay) (retired) 2017-08-31 12:47:57 UTC
Personally i dont think this was a good idea, especially when the better way to go is to provide users with a simplified options dialog (bug 90989) and we can still retain the complex options dialog that we have today.
Comment 9 V Stuart Foote 2017-11-08 14:55:11 UTC
@Mike, as noted in comment 7, the Quickstart/QuickLaunch could be toggled from this panel of the Options dialog--where did it get relocated? Or is it in Expert Config as well (I couldn't find it)?
Comment 10 Mike Kaganski 2017-11-08 14:57:12 UTC
Oh! Missed that actually. Need to move it somewhere...
Comment 11 V Stuart Foote 2017-11-08 15:28:04 UTC
(In reply to Mike Kaganski from comment #10)
> Oh! Missed that actually. Need to move it somewhere...

LO: General, or maybe Load/Save: General (since quickstart is supposed to be helpful for shorter opening).  Otherwise a new stanza in Expert Configuration?
Comment 12 Mike Kaganski 2017-11-08 20:16:18 UTC
Restored the setting on General page: https://gerrit.libreoffice.org/44508
Comment 13 Commit Notification 2017-11-09 03:37:37 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6502ebb0e977f6bea305e5e1598520a6b8b9f770

Related: tdf#110448: move Quickstart options to General page

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 pioutw 2018-07-04 00:23:03 UTC
this bug is a problematic for Ubuntu and Linux Mint users who have installed the last LTS version of their preferred OS
nearly 200 of my linux clients have LO installed, i can't tell them to upgrade their OS while this bug is still present (a lot of them are using the fast start and some of them need to set the memory at a higher value)

i've tested the patch on 6.0.3 > not working & can't delete it
(installed the zip with the extension manager, i hope this is the right way to do it)

and the bug is also present in 6.0.5 & 6.0.5.2 (versions easy to install)

could you tell when it will be solved ?
Comment 15 Mike Kaganski 2018-07-04 00:28:38 UTC
(In reply to pioutw from comment #14)
> could you tell when it will be solved ?

Which specific bug are you talking about? This bug 110448 is dedicated to removal of the memory page from Options, and it was done in 6.0 (so that the page is removed successfully). We don't expect this to be fixed further. Users who need Quickstart now find the relevant option on General page. Users who need to change memory settings (why, btw? is that really needed, or is there a misunderstanding among your users what the LO memory settings actually do, and a cargo cult?), can use Expert configuration on Advanced tab, looking for values mentioned in comment 0.
Comment 16 Mike Kaganski 2018-07-04 00:37:45 UTC
And by the way: Linux quickstart is finally removed completely in https://cgit.freedesktop.org/libreoffice/core/commit/?id=3e9c908b73f0fe0978c9980750a06bbc9e02295e, which will be in 6.1 already.
Comment 17 pioutw 2018-07-06 11:09:32 UTC
memory setting is not a problem since we can set it in the advanced section

but for me, this:
"And by the way: Linux quickstart is finally removed completely in "
is the biggest regression i've ever seen in a program
I hope this will not encourage Linux users to switch back to Win

thank you for your answer Mike