Bug 110736 - SAVING : Calc freezes during saving a remote file on Google Drive
Summary: SAVING : Calc freezes during saving a remote file on Google Drive
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CMIS
  Show dependency treegraph
 
Reported: 2017-07-31 16:55 UTC by Thomas S.
Modified: 2021-06-20 03:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas S. 2017-07-31 16:55:53 UTC
Description:
Calc often freezes when working on a remote file stored on Google Drive.

When saving the file (~1 Mo), it freezes during a dozen of seconds and Calc doesn't respond at all, which gives the impression it just crashed. 
Obviously a saving time seems normal given the file size (I don't have a very good internet speed) but it should tell the user to wait instead of looking like it crashed.

When testing this problem I just ran across another one, probably linked : when I'm on this file, if I click the "file" button in the toolbar (top left of the screen), it freezes in a similar manner (several seconds) and during this time I cannot do anything, waiting for the drop down menu to open. If I move the mouse during this time, the menu closes itself, and I have to click it again, wait 10s without moving etc. I've never encounter that when not on a remote file, so I'm pretty sure Calc communicates with Google Drive in a way or another when clicking on "File" (The task manager shows some network activity).

Steps to Reproduce:
1. File -> Open remote file (I don't know the english menu exactly)
2. Add a service, etc (connect to your Google Drive)
3. Open the desired file from your Google Drive.
4. Save it again (no need to do any modification).
4-bis. Click on "File" in the top menu bar.

Actual Results:  
When you save the file, or if you click the "file" drop down menu, and Calc doesn't respond during a very long time.
I suspect it must last a longer time if the file is bigger (but I've not tried).

Expected Results:
Calc should not freeze, it should only wait for the result of the file saving without preventing the user to do anything.


Reproducible: Always

User Profile Reset: Yes and it didn't fix the problem.

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Xisco Faulí 2017-08-02 21:49:46 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Thomas S. 2017-08-03 09:48:20 UTC
Thank you Xisco for responding quickly.
Actually, I downloaded the Libreoffice in the 5.2 version something like last week, so I thought that was the latest stable version (or maybe it changed very recently). For information, I ran across the same bug in the 5.1.5.2 version I have on another computer on Windows 8.

When I go on the french version (I'm french) of the official LibreOffice website, it tells me the latest stable version is the 5.3.4. On your link, the latest "fresh" version is 5.4.0. Is this the one you advise me to download instead ?
Comment 3 Thomas S. 2017-08-03 17:22:27 UTC
So, I tried with LibreOffice 5.3.4 then 5.4.0.3. The problem is still there, everything works the same way (doesn't respond when saving etc.).

I have another remark though (regardless of the version) : Everything works fine when I edit the file just after opening, but after I have saved once, calc behaves quite slowly and often freezes, when working on the file. It's very annoying.
Comment 4 malboarg 2018-06-19 18:13:43 UTC
The bug is present in:
Version: 6.1.0.0.beta1
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
 
When I click on "File" (step 4bis) it takes average 6 or 7 seconds to respond.
The file tested is small (27kb) ,and my connection is slow (6Mb).
After that, during navigation, sometimes there are some small freezes of 3 or 4 seconds (for instance when I change a cell content).
Comment 5 QA Administrators 2019-06-20 02:50:17 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2021-06-20 03:46:00 UTC
Dear Thomas S.,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug