Download it now!
Bug 111001 - slow opening a document while LO isn't started
Summary: slow opening a document while LO isn't started
Status: RESOLVED DUPLICATE of bug 77444
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-01 18:47 UTC by Bernd Marsch
Modified: 2017-08-03 09:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Marsch 2017-08-01 18:47:54 UTC
Description:
On 2 of my 3 Macs LO ist starting/opening extremely slow a LO-Document, if I double click a oo-document while LO isnt't started.
It happened since LO 5.x.x It happens under El Capitan and Sierra.

Sometimes it takes more than a minute to open the document.

If LO is startet, the document opens quick (less than 2 seconds)

I recently changed my system to sierra. It first seemed to be better. but now it is like El Capitan.

If LO is startetd all works well.

Steps to Reproduce:
1. LO isnt started
2. open a LO documentt
3. wait ...

Actual Results:  
long wait

Expected Results:
starting LO and opening documet in abaout 4-6 seconds


Reproducible: Always

User Profile Reset: yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no
Builds ID: LibreOffice 5.4.0.3


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.1.2 Safari/603.3.8
Comment 1 Xisco Faulí 2017-08-02 17:58:16 UTC Comment hidden (obsolete)
Comment 2 Bernd Marsch 2017-08-02 20:12:47 UTC
Starting LO in SafeMode doesn't help, because the issue doesn't occur if LO is started.

So I deleted ~/Library/Application Support/LibreOffice. I started LO one time to get a new user profile and then quitted LO.
Double Clicking the first document worked fine (starting LO and opening document in about 4-5 seconds). Quitting LO.
Double Clicking the second document worked fine too. Quitting LO.
Double Clicking the third document took about 40 seconds to start LO and open the document.

The issue also occurs with odt-documents.

I tried nearly all LO-Versions since 5.0, always the same.
I reinstalled El Capitan from the scratch, the same.
I installed Sierra, the same.

Today I tried LO Vanilla (5.2.3) from the AppStore. The bug didn't happen until now. 

The only difference I found is the place, where the user profile is stored
LO: ~/Library/Application Support
LO Vanilla: ~/Library/Containers
Comment 3 Alex Thurgood 2017-08-03 06:57:06 UTC
This sounds like the "file only loads on mouse/keyboard movement" bug...

*** This bug has been marked as a duplicate of bug 77444 ***
Comment 4 Bernd Marsch 2017-08-03 09:39:34 UTC
Thank you for the hint. I never tried to move the mouse while waiting for opening the document.

Yes, it is a duplicate of bug 77444. If I move the mouse, the document immediately opens.

But i didn't find the bug in LO 4.4.7 (just tested).