Bug Hunting Session
Bug 111439 - All menu in opening screen items blank, just a placeholder
Summary: All menu in opening screen items blank, just a placeholder
Status: RESOLVED DUPLICATE of bug 107166
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.2.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-08-07 14:59 UTC by Piter Sadroc
Modified: 2017-10-03 10:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Eloquently show the fault on installation- blank lines instead of text (200.62 KB, image/jpeg)
2017-08-07 15:03 UTC, Piter Sadroc
Details
Here's the line only error message... (10.82 KB, image/jpeg)
2017-08-07 15:05 UTC, Piter Sadroc
Details
v5.4.0.3 still shooting blanks (174.38 KB, image/jpeg)
2017-08-09 03:12 UTC, Piter Sadroc
Details
v5.3.1.2 last working copy (281.08 KB, image/jpeg)
2017-08-09 03:16 UTC, Piter Sadroc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piter Sadroc 2017-08-07 14:59:50 UTC
Description:
Every version since after 5.3.1 has blank placeholders for all the names. Just tried v5.4.0.3, uninstalled and reinstalled v5.3.1, which is the last working version
I am using Intel 64 bit HP dv7 6012tx win10 Pro... with all the latest updates...8GB RAM...

Steps to Reproduce:
1.Uninstall older version (though not necessarily)
2.Install newer version
3.Blank lines, uninstall, re-install older version

Actual Results:  
It's not difficult. I install the new version, all the menu items vanish. I uninstall it and re-install the older version, items re-appear. I have tried re-booting in between and not rebooting, I have tried flushing icon cache and not flushing icon cache... I'm simply not clever enough to figure out why

Expected Results:
Blank lines in ALL menu items. And I mean ALL. Reinstalling 5.3.1 gets them ll back again...


Reproducible: Always

User Profile Reset: No

Additional Info:
I have pictures... even the error message is useless...if I can lodge the 2 jpgs


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Piter Sadroc 2017-08-07 15:03:47 UTC
Created attachment 135214 [details]
Eloquently show the fault on installation- blank lines instead of text

I only seem to be able to add one attachment... the 2nd jpg shows a very useless error message
Comment 2 Piter Sadroc 2017-08-07 15:05:46 UTC
Created attachment 135215 [details]
Here's the line only error message...

Sorry, I didn't realize I could add a 2nd file until after I processed the first on....
Comment 3 Xisco Faulí 2017-08-07 15:33:08 UTC
Duplicate of bug 107166.
Please, try with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?

*** This bug has been marked as a duplicate of bug 107166 ***
Comment 4 Piter Sadroc 2017-08-08 00:55:48 UTC
Thank you for your response. However your suggestion that I try the latest version is the final straw the broke the camel's back. I had written in my initial submission that I had tried installing 5.4.0.3 with no happy results... Problem remained, I uninstalled it, reinstalled the last known working version, 5.3.1
Comment 5 Xisco Faulí 2017-08-08 19:01:49 UTC
it's a duplicate of bug 107166 anyway. Please, read the comment from bug 107166 for hints on how to fix it.

*** This bug has been marked as a duplicate of bug 107166 ***
Comment 6 Piter Sadroc 2017-08-09 03:11:33 UTC
The problem HAS NOT BEEN RESOLVED... See attached photos. I re-installed v5.4.0.3 - see what happened in the attached photo. Blanks...
I then uninstalled it and reinstalled the last working copy, v5.3.1.2, and took yet another screen shot.. I really am getting tired of this install-0unistall-re-install merry-go-around. 
The problem HAS NOT BEEN FIXED!
Peter
Comment 7 Piter Sadroc 2017-08-09 03:12:55 UTC
Created attachment 135328 [details]
v5.4.0.3 still shooting blanks
Comment 8 Piter Sadroc 2017-08-09 03:16:35 UTC
Created attachment 135329 [details]
v5.3.1.2 last working copy

This file shows the effect after I re-installed v5.4.0.3, took a screen shot to show the blanks STILL remain in the latest version... though if I keep doing this, there'll be another version. 

I then uninstalled v5.4.0.3 and reinstalled (yet, again) v5.3.1.2 and took a screenshot, this time showing the version number. 
Please check the time stamps on these files. THE PROBLEM HAS NOT BEEN FIXED!
Comment 9 V Stuart Foote 2017-08-14 12:53:34 UTC
Sorry, but there are driver issues with your HP laptop's mixed iGPU/dGPU in the DirectWrite D2Write font rendering implemented at 5.3.2

You did not provide your results of msinfo32.exe or dxdiag.exe so we can not advise you further of where your specific issue is--but none-the-less this is a duplicate of bug 107166.

Steps you need with the laptop iGPU/dGPU are buried in bug 107166, or post the system driver details here--I'll have a look. Suspect you will probably need the Leshcat mod drivers to make this stable on your hardware combination.

=-ref-=
http://leshcatlabs.net/
Comment 10 Piter Sadroc 2017-08-14 13:10:16 UTC
Thanks for getting back to me... However... a reality check... I did not understand 3/4 of what you said, let alone know how to do it. 

I imagine most users of your software are about as ignorant as I am of the inner workings of your program. Just as person doesn't need an engineering degree to drive a car- they don't need to know how every widget works, nor do they need to know how to repair every fault a car may develop- there are experts who get paid good money - they're called mechanics. Now, a mechanic can blind a person a with technical jargon that would flummox most people, but all the owner of the car wants to know- can he fix it? can I drive it away today? 

To learn that the car has an incompatible doo-dad means nothing to the owner. They wonder why a manufacturer creates a product that requires such bizarre features as to make them inoperable if they hold they tongue the wrong way.

So, back to my PC.... It oughtn't matter what is "under the hood" to me. I know I can and do use the latest operating system and it's associated patches...However, I find it absurd that every designer of software suddenly thinks the rest of the world shares their love of the inscrutable. No, no we don't. We just want software to work. It's your job to make it work... And if you can't do it ... then find someone who can. We dumb end users don't need to know how or why things work- or don't. We just need to know that the people who made this thing that doesn't work now, how to make it work again without me turning into a pretzel doing convolutions over the PC innards we don't understand.
We do not share your enthusiasm or ease of repartee over some technical obscurity. I can almost see where Apple users come from...And I own zero Apple products...

Sorry to rant, but really people, a reality check... Take one. Go out and smell the roses for a change. 
Piter
Comment 11 V Stuart Foote 2017-08-14 13:59:02 UTC
(In reply to Piter Sadroc from comment #10)

This is a BZ issue report service--not a help desk. Although I had offered to help you directly and the specific NEEDINFO was to you, you waste our time.

> ...
> So, back to my PC.... It oughtn't matter what is "under the hood" to me. I
> know I can and do use the latest operating system and it's associated
> patches...However, I find it absurd that every designer of software suddenly
> thinks the rest of the world shares their love of the inscrutable. No, no we
> don't. We just want software to work.
> ...

As do we all do. But the issue here remains _your_ hardware/driver combination where the "latest operating system and it's associated patches" can not resolve it. You could take it up with HP or AMD but that is proven to be fruitless by others with the AMD hybrid GPU controls and the reason for the Leshcat driver project.

*** This bug has been marked as a duplicate of bug 107166 ***
Comment 12 Piter Sadroc 2017-08-14 14:05:57 UTC
Except, oddly I have no problem with any other software running on my PC. My first reaction is not "I've got a heart attack", my PC is broken, but "It's heartburn, some ingredient isn't working" In view of the functionality of all other systems being hunky dory, the only glitch was with your software. And I do mean the ONLY glitch... So, stupid me, thought "it's a problem with this bit of software I'm trying to install" not "Oh, my goodness, the sky is falling down, my HP laptop is going pear shaped!" Hence, the thought of needing a computer version of "open heart surgery" never occurred to me, coz, being a tech idiot, I assumed that, well, everything else works as advertised except this bit of software...
Comment 13 Piter Sadroc 2017-08-14 14:12:11 UTC
And who knows what a "Leshcat" is in captivity? Speak English, people. Not Esperanto.... or whatever it means.. Which, no doubt some people have an affection for. But please don't assume us village idiots know what all those words even mean, let alone know that we should do something arcane (to us numbnuts)  first.... You make it possible for your program to have feedback... well, I've given you feedback on a level Mr Joe Public understands, and then I get a response in techno-babble... I just want it to work. I have recommended your software to many people over the years, I didn't think that getting help would be quite so... challenging, or disappointing...
Comment 14 V Stuart Foote 2017-08-14 14:23:20 UTC
OK I'll try to be clear.
 
LibreOffice 5.3 and on will not work correctly with your hardware/driver combination, either update your drivers, adjust your BIOS/Catalyst controls to force the Intel iGPU or the AMD dGPU active with LibreOffice, maybe both. 

Or simply stay with the 5.2.7 build of LibreOffice if it is functional for you.

LibreOffice is not perfect in its DirectWrite implementation, but we can not fix what is wrong with the DirectWrite implementation in the Catalyst drivers provided by AMD to HP.

Your issue is NOTOURBUG as are the residuals folks have with bug 107166
Comment 15 Piter Sadroc 2017-08-14 14:24:51 UTC
Thank you. Nice and clear... I'll go and have a cold shower to cool off now.
Comment 16 M. 2017-10-03 10:24:12 UTC Comment hidden (no-value)
Comment 17 Aron Budea 2017-10-03 10:31:05 UTC

*** This bug has been marked as a duplicate of bug 107166 ***