Bug Hunting Session
Bug 111529 - FILESAVE DOCX Writer Corrupts Tabs In Header and Footer of Word Document
Summary: FILESAVE DOCX Writer Corrupts Tabs In Header and Footer of Word Document
Status: RESOLVED DUPLICATE of bug 63561
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2017-08-08 18:55 UTC by junk_2010
Modified: 2018-10-08 21:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original Word Document (16.09 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-08-08 18:55 UTC, junk_2010
Details
Word document after LibreOffice header and footer tab corruption (11.09 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-08-08 18:56 UTC, junk_2010
Details
Screenshot of header tabs in Word 2013 (104.44 KB, image/png)
2017-08-08 18:57 UTC, junk_2010
Details
Screenshot of footer tabs in Word 2013 (118.08 KB, image/png)
2017-08-08 18:58 UTC, junk_2010
Details
Screenshot of header and footer tabs on first opening in LibreOffice Writer (45.75 KB, image/png)
2017-08-08 18:59 UTC, junk_2010
Details
Screenshot of header and footer tabs after edit in LibreOffice Writer (50.31 KB, image/png)
2017-08-08 19:02 UTC, junk_2010
Details

Note You need to log in before you can comment on or make changes to this bug.
Description junk_2010 2017-08-08 18:55:38 UTC
Created attachment 135310 [details]
Original Word Document

I have an issue where LibreOffice writer corrupts the tabs in the header and footer of a previously created word document.
The example word document I have attached "TabBug_original.docx" was created in Word 2013.
The document "TabBug_original_after_writer_edit.docx" is after I have made a small text edit to the main body of the document. You can see that additional tabs are now present in the header and footer of the document. In fact these additional tabs can be created by just opening the original document in LibreOffice writer and pressing "save", without making any edits.

Steps to re-create the issue:

1) Create original document in Word 2013. Screenshot documents "Word_2013_header_tabs.PNG" and "Word_2013_footer_tabs.PNG" show the header and footer tabs.

2) Open the document in LibreOffice writer. On first opening the header and footer tabs are as expected. See screenshot "LibreOffice_5.3.4.2_header_and_footer_on_first_opening.PNG".

3) Make a small edit to the document, save, exit LibreOffice writer.

4) Re-open the edited document in LibreOffice writer and you will see additional tabs in the header and footer. See the screenshot "LibreOffice_5.3.4.2_header_and_footer_after_edit.PNG"

I believe this issue has existed for some time. The documents and screenshots I created were using LibreOffice 5.3.4.2 on Windows 10. I also tried LibreOffice 5.4.0.3 on Windows 10 and saw the same issue.
Comment 1 junk_2010 2017-08-08 18:56:55 UTC
Created attachment 135311 [details]
Word document after LibreOffice header and footer tab corruption
Comment 2 junk_2010 2017-08-08 18:57:43 UTC
Created attachment 135312 [details]
Screenshot of header tabs in Word 2013
Comment 3 junk_2010 2017-08-08 18:58:39 UTC
Created attachment 135313 [details]
Screenshot of footer tabs in Word 2013
Comment 4 junk_2010 2017-08-08 18:59:39 UTC
Created attachment 135314 [details]
Screenshot of header and footer tabs on first opening in LibreOffice Writer
Comment 5 junk_2010 2017-08-08 19:02:44 UTC
Created attachment 135315 [details]
Screenshot of header and footer tabs after edit in LibreOffice Writer
Comment 6 Buovjaga 2017-08-26 17:42:35 UTC
Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 3c49b28ffa7ab062726e5e600312d9164224404e
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 26th 2017

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 7 junk_2010 2018-03-12 20:53:33 UTC
Still present in released LibreOffice:

Version 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-GB (en_GB); Calc: group

Running on Windows 10.
Comment 8 junk_2010 2018-08-07 18:48:06 UTC
Still present in released LibreOffice:

Version: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-GB (en_GB); Calc: group

Running on Windows 10.
Comment 9 Justin L 2018-08-11 13:51:15 UTC
fixed in LO 6.1.1 with fix from bug 63561

*** This bug has been marked as a duplicate of bug 63561 ***
Comment 10 junk_2010 2018-10-08 21:35:33 UTC
I can confirm that this bug is fixed as of 6.1.1.2 64bit on Windows 10.