Download it now!
Bug 111630 - Truetype Font Wingdings has additional space after each character
Summary: Truetype Font Wingdings has additional space after each character
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-08-10 09:18 UTC by Karsten
Modified: 2020-03-22 17:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem (40.26 KB, image/png)
2017-08-10 09:18 UTC, Karsten
Details
Problem in V 6.02 (24.66 KB, image/png)
2018-03-07 08:56 UTC, Karsten
Details
Using wingdings in gimp (29.49 KB, image/png)
2018-03-08 11:10 UTC, Karsten
Details
Problem reduced to the first sign (32.96 KB, image/png)
2018-03-08 11:19 UTC, Karsten
Details
Video of using wingdings and other fonts (1.72 MB, video/mp4)
2018-05-03 07:37 UTC, Karsten
Details
Actual screenshot (81.15 KB, image/png)
2019-08-25 08:53 UTC, Karsten
Details
The installed font (69.39 KB, application/x-font-ttf)
2019-08-25 08:55 UTC, Karsten
Details
Problem in 6.2.8.2 (22.01 KB, application/pdf)
2020-02-23 09:08 UTC, Karsten
Details
Everything new (19.67 KB, application/pdf)
2020-02-27 09:21 UTC, Karsten
Details
Everything new (9.13 KB, application/vnd.oasis.opendocument.text)
2020-02-27 09:22 UTC, Karsten
Details
No problem on Linux (22.00 KB, application/pdf)
2020-02-28 12:17 UTC, Buovjaga
Details
screenshot (167.37 KB, image/png)
2020-03-02 15:38 UTC, Karsten
Details
screenshot odt (10.01 KB, application/vnd.oasis.opendocument.text)
2020-03-02 15:39 UTC, Karsten
Details
screenshot pdf (38.55 KB, application/pdf)
2020-03-02 15:39 UTC, Karsten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karsten 2017-08-10 09:18:26 UTC
Description:
After upgrading to release 5.3.4.2 the Truetype font Webdings has an additional space after each character.
At least every character takes the double space.
The problem is not given with the font Systemdings.

This problem is the same in the other components like Calc.

Steps to Reproduce:
Use the truetype font Webdings.

Actual Results:  
double space

Expected Results:
normal space


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Karsten 2017-08-10 09:18:55 UTC
Created attachment 135399 [details]
Screenshot of the problem
Comment 2 Buovjaga 2017-08-28 18:10:10 UTC
I don't have Wingdings on Linux, but on Windows it looks fine.
Please try with LibreOffice 5.4 to be sure.

Win 10
Version: 5.4.0.3 (x64)
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 QA Administrators 2018-03-02 10:01:46 UTC Comment hidden (obsolete)
Comment 4 Karsten 2018-03-03 11:15:02 UTC
Please refer to https://bugs.documentfoundation.org/show_bug.cgi?id=115038
Comment 5 Buovjaga 2018-03-03 15:32:08 UTC
(In reply to Karsten from comment #4)
> Please refer to https://bugs.documentfoundation.org/show_bug.cgi?id=115038

Why?
Comment 6 Karsten 2018-03-03 18:39:11 UTC
Why not?

I have no idea, but this problems seems to belong together.
Comment 7 Buovjaga 2018-03-03 18:43:01 UTC
(In reply to Karsten from comment #6)
> Why not?
> 
> I have no idea, but this problems seems to belong together.

Because the request was "Please try with LibreOffice 5.4 to be sure."
Did you?
Comment 8 Karsten 2018-03-03 19:19:21 UTC
You can read there that i tested examples 4.4.3.2 and 5.4.4.2 with writer and impress
Comment 9 Buovjaga 2018-03-04 07:20:28 UTC
Thomas: are you able to confirm this?
Comment 10 Karsten 2018-03-04 10:04:08 UTC
I don't know what you really want, but i think the question is if this bug should be better solved in bug 115038 ?

Then i will say yes, because this here seems only to be an side effect.
Comment 11 Buovjaga 2018-03-04 10:08:03 UTC
(In reply to Karsten from comment #10)
> I don't know what you really want, but i think the question is if this bug
> should be better solved in bug 115038 ?
> 
> Then i will say yes, because this here seems only to be an side effect.

No, I was speaking to Thomas.
Comment 12 Karsten 2018-03-04 10:10:51 UTC
O.K. then see this as hint or opinion as you like. :-)
Comment 13 Thomas Lendo 2018-03-05 01:00:36 UTC
I can't reproduce this with

Version: 6.0.1.1
Build-ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU-Threads: 4; BS: Linux 4.13; UI-Render: Standard; VCL: gtk2; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

and

Version: 6.1.0.0.alpha0+
Build ID: e108a31a8fee09c2fa4031e45e45ed73bbdb7c6f
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-03-04_00:58:03
Locale: de-DE (de_DE.UTF-8); Calc: group

Haven't tested with 5.4 or 5.3 as I've installed them on my Linux machine.

Karsten can you try a 6.0 [1] or 6.1 version of LibreOffice?
Where is the screenshot from? Looks like Windows.

[1] https://www.libreoffice.org/download/download/
[2] https://dev-builds.libreoffice.org/daily/master/ (https://wiki.documentfoundation.org/Installing_in_parallel/Linux)
Comment 14 Karsten 2018-03-05 09:52:35 UTC
The bug is listed under Linux.
I am using Debian Jessie (8.10) for the desktop currently.

Testing with libreoffice version 6 will take some time, please remember me if i forgot it.
Comment 15 Buovjaga 2018-03-05 10:14:04 UTC
(In reply to Karsten from comment #14)
> The bug is listed under Linux.
> I am using Debian Jessie (8.10) for the desktop currently.
> 
> Testing with libreoffice version 6 will take some time, please remember me
> if i forgot it.

An appimage is a quick way to test: https://www.libreoffice.org/download/appimage
Comment 16 Karsten 2018-03-07 08:56:31 UTC
Created attachment 140414 [details]
Problem in V 6.02

Version: 6.0.2.1
Build-ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU-Threads: 4; BS: Linux 3.16; UI-Render: Standard; VCL: kde4; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: CL
Comment 17 Karsten 2018-03-07 08:57:30 UTC
Version 6 seems to be stable now so i upgraded generally.

Version: 6.0.2.1
Build-ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU-Threads: 4; BS: Linux 3.16; UI-Render: Standard; VCL: kde4; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: CL

As you can see https://bugs.documentfoundation.org/attachment.cgi?id=140414
the problem has not gone.
Comment 18 Thomas Lendo 2018-03-07 18:55:58 UTC
Maybe it's a KDE-Problem. Have you tested other programs?

Have you tried with a fresh LibO user profile?
Comment 19 Buovjaga 2018-03-07 20:11:39 UTC
Karsten can try by launching from the command line with
SAL_USE_VCLPLUGIN=gen libreoffice
Comment 20 Karsten 2018-03-08 11:10:54 UTC
Created attachment 140466 [details]
Using wingdings in gimp
Comment 21 Karsten 2018-03-08 11:12:26 UTC
Please remember that this problem does not exist in Libreoffice < release 5.3.4.2
Comment 22 Karsten 2018-03-08 11:19:19 UTC
Created attachment 140467 [details]
Problem reduced to the first sign

Why for the hell everything is resetted in writer after inserting one special case?
Every time the font must be selected new!
Comment 23 Buovjaga 2018-03-08 12:01:19 UTC
(In reply to Karsten from comment #21)
> Please remember that this problem does not exist in Libreoffice < release
> 5.3.4.2

To be clear, did you update from version 5.3.3? Or 5.2.x?
Comment 24 Karsten 2018-03-08 12:16:28 UTC
Sorry - i don't know - it is to long ago.
But i always used the stable releases.
Comment 25 Buovjaga 2018-03-08 12:31:37 UTC
(In reply to Karsten from comment #24)
> Sorry - i don't know - it is to long ago.
> But i always used the stable releases.

It's just that the font rendering engine was changed to HarfBuzz in 5.3.0.

You can test old releases as appimages, just download and set the file to be executable: https://libreoffice.soluzioniopen.com/index.php/old-versions/
Comment 26 Thomas Lendo 2018-03-11 10:50:15 UTC
It can be a HarfBuzz issue but there must be at least one person who can reproduce this.
Comment 27 Karsten 2018-03-11 13:32:11 UTC
I thought you can reproduce it?
https://bugs.documentfoundation.org/show_bug.cgi?id=115038#c9

And i have the exact same behaviour on 2 PC's and 1 notebook all running Debian 8.
Maybe i can Test with Debian 9 ...
Comment 28 Thomas Lendo 2018-03-11 18:13:22 UTC
But this issue I can't reproduce. Maybe there is something, a step which is missing in my tests and therefore I don't see the issue.
Comment 29 Xisco Faulí 2018-05-02 09:48:09 UTC
(In reply to Thomas Lendo from comment #28)
> But this issue I can't reproduce. Maybe there is something, a step which is
> missing in my tests and therefore I don't see the issue.

Dear Karsten,
Could you please create and attach a screencast showing the steps?
There are various free screencast software available for use, including Camstudio (Windows), Jing (Mac), Simple Screen Recorder (Linux) or screencast-o-matic.com (Web).

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested screencast is provided.
Comment 30 Karsten 2018-05-03 07:37:58 UTC
Created attachment 141857 [details]
Video of using wingdings and other fonts

I hope this helps.
Video of using wingdings in writer
Version: 6.0.2.1
Build-ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU-Threads: 4; BS: Linux 3.16; UI-Render: Standard; VCL: kde4; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: CL
Comment 31 Thomas Lendo 2018-05-03 20:14:21 UTC
Can't still reproduce it, sorry. Maybe a kde4 special problem?

Version: 6.1.0.0.alpha1+
Build ID: f5a56c367fba1c42b4f9719b10ff3e86ad5e2ab1
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 32 Karsten 2018-05-03 20:23:28 UTC
Maybe.

Maybe a problem of special settings within KDE?
But then it should not be rendered false in libreoffice.
Comment 33 Karsten 2018-05-03 20:24:55 UTC
When the next version of libreoffice get's stable?

Or can Version: 6.1.0.0.alpha1+ be seen as stable as my version i am using?
Comment 34 Dieter 2018-05-03 20:34:06 UTC
(In reply to Karsten from comment #33)
> When the next version of libreoffice get's stable?
> 
> Or can Version: 6.1.0.0.alpha1+ be seen as stable as my version i am using?

LO 6.1.0.0 will be installed separatly - so you can still use your actual stable version of LO.
Comment 35 Buovjaga 2018-05-03 20:51:30 UTC
(In reply to Dieter Praas from comment #34)
> LO 6.1.0.0 will be installed separatly - so you can still use your actual
> stable version of LO.

Or try https://libreoffice.soluzioniopen.com/index.php/pre-releases/
and like I said in comment 25, try the older appimages to find the exact version where the problem appeared.
Comment 36 Dieter 2018-06-18 21:23:50 UTC
Karsten, have you tried it with a newer version or have you tried the older appimages to find the exact version where the problem appeared (see previous comment)?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 37 Karsten 2018-08-26 14:49:21 UTC
Sorry that i did not answer for a long time.
I did not have the time for futher tests.

I should check this in a fresh install of Debian 9.
But i am still working in Debian 8 because there is no time to migrate my data ...
Comment 38 Buovjaga 2018-08-26 14:57:35 UTC
(In reply to Karsten from comment #37)
> Sorry that i did not answer for a long time.
> I did not have the time for futher tests.
> 
> I should check this in a fresh install of Debian 9.
> But i am still working in Debian 8 because there is no time to migrate my
> data ...

No need to update Debian, if you just download an appimage of LibreOffice and run it.
Comment 39 QA Administrators 2019-03-21 11:12:20 UTC Comment hidden (obsolete)
Comment 40 Karsten 2019-03-21 12:10:52 UTC
It's still the same in Version 6.1.5.2
Comment 41 Xisco Faulí 2019-04-12 10:57:46 UTC
(In reply to Karsten from comment #40)
> It's still the same in Version 6.1.5.2

Yep, LibreOffice 6.1 uses KDE4 so nothing has changed there. You should try with LibreOffice 6.2 which uses KDE5
Comment 42 Khaled Hosny 2019-08-21 23:01:43 UTC
Where do I get the problematic font?
Comment 43 Buovjaga 2019-08-22 03:19:41 UTC
(In reply to Khaled Hosny from comment #42)
> Where do I get the problematic font?

"Just" install Windows :)
Comment 44 Khaled Hosny 2019-08-22 08:06:33 UTC
(In reply to Buovjaga from comment #43)
> (In reply to Khaled Hosny from comment #42)
> > Where do I get the problematic font?
> 
> "Just" install Windows :)

Right. Got it. Can’t reproduce as well. Closing as WFM, if someone can reproduce this with latest release please reopen.
Comment 45 Khaled Hosny 2019-08-22 08:10:55 UTC
(In reply to Khaled Hosny from comment #44)
> (In reply to Buovjaga from comment #43)
> > (In reply to Khaled Hosny from comment #42)
> > > Where do I get the problematic font?
> > 
> > "Just" install Windows :)
> 
> Right. Got it. Can’t reproduce as well. Closing as WFM, if someone can
> reproduce this with latest release please reopen.

It is also possible the specific version of the font that OP has is faulty. The one I tested with is version 5.01.
Comment 46 Karsten 2019-08-25 08:53:09 UTC
The bug is still present.
I will attach an screenshot and the font
Comment 47 Karsten 2019-08-25 08:53:47 UTC
Created attachment 153630 [details]
Actual screenshot
Comment 48 Karsten 2019-08-25 08:55:04 UTC
Created attachment 153631 [details]
The installed font
Comment 49 Buovjaga 2019-08-25 09:13:58 UTC
Karsten: please try with 6.3. An appimage is an easy way https://libreoffice.soluzioniopen.com/
Comment 50 Buovjaga 2019-08-25 09:22:46 UTC
Btw. I installed Wingdings on Linux and there is no problem

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: b9a776837462eeb6d50d0decc42604c0c3008eb1
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 August 2019
Comment 51 Khaled Hosny 2019-08-26 03:34:02 UTC
(In reply to Karsten from comment #48)
> Created attachment 153631 [details]
> The installed font

I can’t reproduce with the attached font, and you are not using the latest release either.
Comment 52 QA Administrators 2020-02-23 02:48:07 UTC Comment hidden (obsolete)
Comment 53 Karsten 2020-02-23 09:08:04 UTC
Created attachment 158111 [details]
Problem in 6.2.8.2

After such a long time and multiple releases it is normal to give up.
You have written that you can't reproduce it - so you can't trace the problem.

It seems that the problem is caused in the combination with the setup of KDE / distribution.
Maybe settings within the language german.
I should test it in Debian 10, because in Debian 8 it is still present.

Now i must first install the latest stable release.
But it is easier just to avoid Windings.

Here it is still present.
Comment 54 QA Administrators 2020-02-24 02:32:45 UTC Comment hidden (obsolete)
Comment 55 Dieter 2020-02-24 10:41:00 UTC
(In reply to Karsten from comment #53)
> I should test it in Debian 10, because in Debian 8 it is still present.
> 
> Now i must first install the latest stable release.
> But it is easier just to avoid Windings.
> 
> Here it is still present.

So let's keep report in status NEEDINFO until you could test it with a more recent version.
Comment 56 Karsten 2020-02-27 09:21:33 UTC
Created attachment 158221 [details]
Everything new
Comment 57 Karsten 2020-02-27 09:22:22 UTC
Created attachment 158222 [details]
Everything new

It‘s almost the same.
Now in a complete new installation of Debian 10
Comment 58 Buovjaga 2020-02-27 10:58:52 UTC
(In reply to Karsten from comment #57)
> Created attachment 158222 [details]
> Everything new
> 
> It‘s almost the same.
> Now in a complete new installation of Debian 10

With LibreOffice version 6.3.5.2
Comment 59 Dieter 2020-02-28 11:12:54 UTC
(In reply to Karsten from comment #57)
> Created attachment 158222 [details]
> Everything new
> 
> It‘s almost the same.
> Now in a complete new installation of Debian 10

When I open this attachment, everything is O.K. So just for clarification (because I can't see this in attachment from comment 56): There is no additional space character, but only additional space, right?
Comment 60 Karsten 2020-02-28 12:14:28 UTC
The meaning of your question is not clear?

The space character can be seen on the screen and in the print / pdf of it.

When using the font windings there is no additional space entered between the characters.
You can check it in the odt https://bugs.documentfoundation.org/attachment.cgi?id=158222
This one is exported to the pdf https://bugs.documentfoundation.org/attachment.cgi?id=158221
Comment 61 Buovjaga 2020-02-28 12:17:43 UTC
Created attachment 158254 [details]
No problem on Linux

Exported attachment 158222 [details] to PDF with

Arch Linux 64-bit
Version: 7.0.0.0.alpha0+
Build ID: 79d396a2a64bec4e6c9aa514af40fdd67a62d8ce
CPU threads: 8; OS: Linux 5.5; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 26 February 2020
Comment 62 Dieter 2020-02-28 16:52:40 UTC
(In reply to Karsten from comment #60)
> When using the font windings there is no additional space entered between
> the characters.

Sorry, but now I'm a little confused: So the problem doesn't exist in the odt-file, but only in exported PDF???

I still can't confirm problem with

Version: 6.3.5.2 (x64)
Build-ID: dd0751754f11728f69b42ee2af66670068624673
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 63 Karsten 2020-02-28 16:53:33 UTC
I believe this.

But as already told this problem is given in Debian 8 and 10.
I can test it in Debian 9, but that would make no difference.

There was already opened another bug that the formatting is different on other PC's running the same Linux and Libreoffice.
So this is not really an forte of Libreoffice. ;-)

When you can't reproduce it you have no chance to debug it.
Sometimes problems cannot be solved. :-)
Comment 64 Karsten 2020-02-28 16:54:50 UTC
(In reply to Dieter from comment #62)
> (In reply to Karsten from comment #60)
> > When using the font windings there is no additional space entered between
> > the characters.
> 
> Sorry, but now I'm a little confused: So the problem doesn't exist in the
> odt-file, but only in exported PDF???

The problem exists on the screen and in the PDF.
Do you need an screenshot to believe?
Comment 65 Dieter 2020-02-29 15:49:29 UTC
(In reply to Karsten from comment #64)
> The problem exists on the screen and in the PDF.
> Do you need an screenshot to believe?

I believe you, of course. I'm also sure, you've checked settings of character spacing in Format => Character => Position.
Comment 66 Karsten 2020-03-01 10:39:03 UTC
(In reply to Dieter from comment #65)
> I believe you, of course. I'm also sure, you've checked settings of
> character spacing in Format => Character => Position.

You can check it for yourself, because the odt is attached.
Comment 67 Dieter 2020-03-02 07:06:54 UTC
(In reply to Karsten from comment #66)
> You can check it for yourself, because the odt is attached.

Yes of, course, but I don't see spaces after characters and therefore it's no surprise, that setting of character spacing is 0.
Comment 68 Karsten 2020-03-02 15:38:24 UTC
Created attachment 158314 [details]
screenshot

So here is an screenshot with the corresponding document and pdf.
Comment 69 Karsten 2020-03-02 15:39:15 UTC
Created attachment 158315 [details]
screenshot odt
Comment 70 Karsten 2020-03-02 15:39:48 UTC
Created attachment 158316 [details]
screenshot pdf
Comment 71 Jean-Baptiste Faure 2020-03-22 17:13:44 UTC
I confirm the problem with the attached Wingdings font. Tested on both LO 6.4.3.0+ and the master under Ubuntu 18.04 x86-64 with Gnome.

Version : 6.4.3.0.0+
Build ID : 2f98d1179479f81b2c4d99004d8fcf7c1bc0c6a5
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

Best regards. JBF