Bug Hunting Session
Bug 111631 - EDITING: The font spacing of some characters is changing slightly when changing the font color
Summary: EDITING: The font spacing of some characters is changing slightly when changi...
Status: RESOLVED DUPLICATE of bug 61444
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-08-10 09:20 UTC by Telesto
Modified: 2019-03-27 17:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (12.03 KB, application/vnd.oasis.opendocument.text)
2017-08-10 09:21 UTC, Telesto
Details
Screencast1 (334.50 KB, video/avi)
2017-08-10 12:55 UTC, Telesto
Details
Screencast2 (275.00 KB, video/avi)
2017-08-10 12:56 UTC, Telesto
Details
Example file two (Impress) (11.59 KB, application/vnd.oasis.opendocument.presentation)
2017-08-28 13:31 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-08-10 09:20:50 UTC
Description:
Not sure if it's worth a report, but: the font spacing of some characters is changing slightly when changing the font color

Steps to Reproduce:
1. Open the attached file
2. Select "hendrerit" (in the colored row) and set font color to black. Switch back and forward with CTRL+Z and CTRL+Y
Notice the change in position of the 'o' in dolor the 'E' of Etiam and the 'l' of aliquet.

Actual Results:  
Some characters are changing position

Expected Results:
Changing the font color shouldn't affect the spacing between characters (I suppose) 


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: 386fcf9be786b302cd2c6f85ff6d8d97a6777926
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-06_01:57:50
Locale: nl-NL (nl_NL); Calc: CL

and in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2017-08-10 09:21:09 UTC
Created attachment 135401 [details]
Example file
Comment 2 Jacques Guilleron 2017-08-10 12:44:33 UTC
Hi Telesto,
I don't reproduce with
LO  6.0.0.0.alpha0+ Build ID: 88179e3de8865ea07d5017ca0723afd10ad44ba7
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-08-06_23:49:25
Locale: fr-FR (fr_FR); Calc: CL
Comment 3 Telesto 2017-08-10 12:55:25 UTC
Created attachment 135412 [details]
Screencast1
Comment 4 Telesto 2017-08-10 12:56:31 UTC
Created attachment 135413 [details]
Screencast2
Comment 5 Regina Henschel 2017-08-10 22:23:10 UTC
I see the little shift. For inside the changed area it might be a result of different kerning. But I have no idea why a single character shifts, which is outside the changed area.
Tested with Version: 5.2.7.2
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: de-DE (de_DE); Calc: group
Comment 6 Telesto 2017-08-28 13:31:28 UTC
Created attachment 135826 [details]
Example file two (Impress)

Similar or same behavior with Impress. The font spacing shifts a little when entering the title textbox, by clicking somewhere between AAAbbb. It seems depended on the zoomfactor. No issue with for example 91%-100%, but it happens with 40% or 110%
Comment 7 Khaled Hosny 2018-02-16 15:23:54 UTC
Might be related to/duplicate of bug 61444.
Comment 8 Khaled Hosny 2019-03-27 17:43:11 UTC

*** This bug has been marked as a duplicate of bug 61444 ***