Bug Hunting Session
Bug 111740 - Wrong preview of graphic bullet symbol in Impress
Summary: Wrong preview of graphic bullet symbol in Impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: kurtaazz
URL:
Whiteboard: target:6.0.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicUI
Depends on:
Blocks:
 
Reported: 2017-08-12 18:12 UTC by Tamás Zolnai
Modified: 2017-11-16 21:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the preview and the document (93.21 KB, image/png)
2017-08-12 18:12 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-08-12 18:12:32 UTC
Description:
In Impress we can set any graphic as bullet symbol. The issue here is that on the Customize tab page where this setting can be selected the preview image displays a wrong bulleting alignemnt. It renders the graphic bullet point aligned to the top of the line, however in the document it will be rendered on the center of the line.

Steps to Reproduce:
1. Open Impress
2. Click into the title shape
3. Open numbering dialog Customize tab page
4. Select Graphic in "Number" field
5. Select a graphic from Gallery (button next to "Graphics:" label)

Actual Results:  
Preview renders bulleting vertically aligned to top of the text line.

Expected Results:
Preview should display bullet symbols as aligned vertically to the center.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.90 Safari/537.36
Comment 1 Tamás Zolnai 2017-08-12 18:12:52 UTC
Created attachment 135497 [details]
Screenshot of the preview and the document
Comment 2 Telesto 2017-08-13 16:38:32 UTC
Repro with:
Version: 6.0.0.0.alpha0+
Build ID: f1a896c71c495bdef5861eb664581507b6b9b5bb
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-13_07:38:19
Locale: nl-NL (nl_NL); Calc: CL
Comment 3 Tamás Zolnai 2017-08-14 23:32:30 UTC
Let's turn it into a easy hack. The code is here:
cui/source/tabpages/numpages.cxx
Check SvxNumberingPreview class.
Comment 4 Shubham Gupta 2017-08-22 11:48:17 UTC
Hi! I am starting to work on this bug.
Comment 5 Shubham Gupta 2017-08-22 12:31:45 UTC
HI,this is my first bug in LO ....I checked out SvxNumberingPreview class but was unable to find something...please guide me.
Comment 6 Tamás Zolnai 2017-08-22 13:23:38 UTC
(In reply to Shubham Gupta from comment #5)
> HI,this is my first bug in LO ....I checked out SvxNumberingPreview class
> but was unable to find something...please guide me.

I would add a breakpoint in lcl_DrawGraphic() method and check where it is called from and what parameters it is called with and check the calculation in it.
Comment 7 Tamás Zolnai 2017-08-23 10:15:49 UTC
(In reply to Shubham Gupta from comment #4)
> Hi! I am starting to work on this bug.

When you work on a bug assign it to yourself (see Assignee field) and also change the status to assigend.
Comment 8 Shubham Gupta 2017-08-23 11:35:57 UTC
(In reply to Tamás Zolnai from comment #7)
> (In reply to Shubham Gupta from comment #4)
> > Hi! I am starting to work on this bug.
> 
> When you work on a bug assign it to yourself (see Assignee field) and also
> change the status to assigend(In reply to Tamás Zolnai from comment #7)

OOps!!..I forgot to do that .....I am now assigning this bug to me ...and thanks for the guidance.
Comment 9 Shinnok 2017-09-04 12:23:58 UTC
Hi, how's it going? Did you manage to progress? If not we are here to help, let us know if you're stuck.
Comment 10 Xisco Faulí 2017-10-05 02:35:44 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2017-11-05 03:39:03 UTC Comment hidden (obsolete)
Comment 12 Tamás Zolnai 2017-11-05 15:18:28 UTC
Let's reset the assignee, since I don't see any response for months.
Comment 13 Xisco Faulí 2017-11-13 08:46:32 UTC
@Kurtaazz, Do you plan to work on this easyHack?
Comment 14 kurtaazz 2017-11-13 09:03:24 UTC
Yes(In reply to Xisco Faulí from comment #13)
> @Kurtaazz, Do you plan to work on this easyHack?
Comment 15 Commit Notification 2017-11-16 21:36:52 UTC
Mark Vecsernyes committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e1b9212ad4f8d82b6110a525811482a99f6e112

tdf#111740 Wrong preview of graphic bullet symbol in Impress

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.