Bug 111762 - FILESAVE DOCX: Hang when opening file after RT
Summary: FILESAVE DOCX: Hang when opening file after RT
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.6.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Corrupted
  Show dependency treegraph
 
Reported: 2017-08-13 07:25 UTC by Telesto
Modified: 2017-09-12 21:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-08-13 07:25:44 UTC
Description:
Hang when opening file after RT

Steps to Reproduce:
1. Open https://calibre-ebook.com/downloads/demos/demo.docx
2. Save As DOCX
3. Reload the file -> Hang

Actual Results:  
File won't open

Expected Results:
File should be opening


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: 46b4eb8b0e9325f8c29cd391baf9504bccee1837
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-11_06:44:17
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 MM 2017-08-13 09:40:40 UTC
Unconfirmed with Version: 6.0.0.0.alpha0+
Build ID: 4e2b44860c2c304ea728c512b47ca07aaf1cd452
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-08-10_23:01:09
Locale: en-US (en_US.UTF-8); Calc: single

Unconfirmed with Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: single
Comment 2 Jean-Baptiste Faure 2017-08-13 20:31:07 UTC
Not reproducible for me with LO 5.4.2.0.0+ built at home under Ubuntu 16.04 x86-64.

@Telesto: Why did you try a 32 bits version (TinderBox: Win-x86@42) instead of a 64 version when your OS is 64 bits?

Best regards. JBF
Comment 3 MM 2017-08-13 23:11:41 UTC
Confirmed with Version: 5.4.0.3 (x64)
Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
CPU threads: 2; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: single

Strangely enough, filesize changed from 1.3 MB to 9.4MB when saving under windows. Filesize saved with LO under ubuntu is about 5MB.
Comment 4 MM 2017-08-24 20:17:04 UTC
Seems fixed with Version: 5.4.1.1 (x64)
Build ID: a5be49f0c45fe24a575c7f41559aa8fc79a781a2
CPU threads: 2; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: single
Comment 5 Bartosz 2017-09-12 21:38:40 UTC
Confirmed as fixed in LO 5.4.
The size was increased because LO is saving all .odttf fonts into /word/fonts folder.

It is working according to design.