Bug Hunting Session
Bug 111808 - OpenSymbol: Add OpenType MATH table for brackets
Summary: OpenSymbol: Add OpenType MATH table for brackets
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2017-08-14 17:37 UTC by Volga
Modified: 2017-09-03 10:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-08-14 17:37:14 UTC
Description:
If we add MATH table (especially extended shapes) into OpenSymbol font, once we get support for this table, we can making brackts scaled as expected within formulae.

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:
-


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Jean-Baptiste Faure 2017-08-19 07:55:01 UTC
Hi Regina,

What do you think about this proposition?

Best regards. JBF
Comment 2 Regina Henschel 2017-08-19 14:36:56 UTC
I'm no expert for that. But Khaled Hosny is expert for fonts and has already made a change to OpenSymbol.
Comment 3 Jean-Baptiste Faure 2017-08-19 15:57:22 UTC
(In reply to Regina Henschel from comment #2)
> I'm no expert for that. But Khaled Hosny is expert for fonts and has already
> made a change to OpenSymbol.

Ah sorry, will ask Khaled Hosny:
Khaled, what do you think about this enhancement suggestion?

Best regards. JBF
Comment 4 Khaled Hosny 2017-08-19 17:31:11 UTC
The MATH table without corresponding support in Math is if no use. Once Math supports the table, there are plenty of fonts that has it already and not need to touch OpenSymbol.
Comment 5 Volga 2017-08-23 03:10:45 UTC
(In reply to Khaled Hosny from comment #4)
> The MATH table without corresponding support in Math is if no use. Once Math
> supports the table, there are plenty of fonts that has it already and not
> need to touch OpenSymbol.
So which font is suitable to replacing OpenSymbool for math operators, DejaVu Math TeX Gyre?
Comment 6 Khaled Hosny 2017-08-23 09:12:11 UTC
STIX Two Math or TeX Gyre Terms Math since both are Times-like, which matches the style of OpenSymbol.
Comment 7 Buovjaga 2017-09-02 17:18:29 UTC
(In reply to Khaled Hosny from comment #4)
> The MATH table without corresponding support in Math is if no use. Once Math
> supports the table, there are plenty of fonts that has it already and not
> need to touch OpenSymbol.

Ok, let's close.