Bug 111861 - Bad behaviour of status indicator used from basic macros.
Summary: Bad behaviour of status indicator used from basic macros.
Status: RESOLVED DUPLICATE of bug 106281
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-08-16 11:57 UTC by Luis
Modified: 2017-08-16 17:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test file. (10.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-08-16 11:57 UTC, Luis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luis 2017-08-16 11:57:59 UTC
Created attachment 135587 [details]
Test file.

I am using the status indicator to show progress in basic macros.

Behaviour has changed after version 5 (tested up to 5.4.1.0):

1) When you set text with SetText property after set value no progress bar is show.

2) When you call SetValue property the first time after initialization no progress bar is show.

3) When you call SetValue property the next times position of progress bar is the position of the last call to SetValue.

This behaviour is not present in version 4.7.7.2
In old version behaviour is the most logic:

1) When you set text with SetText property after set value the position of the progress bar is NOT changed

2) When you call SetValue property progress bar is always show in the position of the current call to SetValue.

I have made a test calc file with some macros.

To test issue 1 open the attached test file, press button "Start" (Initialises progress bar to max value of 100), 
press "Set value 50" (no progress bar is show), press "Set value 25" (progress bar is show to 50%), press "Set text" (no progress bar is show).

To test issue 2 and 3 open the attached test file, press button "Start", press an arbitrary "Set value" button (no progress bar is show), 
press another "Set value" button (progress bar is show in the position indicated by previous button), 
press another "Set value" button (progress bar is show again in then position indicated by previous button).
Comment 1 Xisco Faulí 2017-08-16 17:17:27 UTC
Steps:
1. Open the attached file
2. Click on start button
3. Click on 'set value to 25' -> progress bar should be filled 25%

Regression introduced in range: https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=a6f876d45bd4e41a7143594a6cb11b6893a0f620..0ab6332f97ec8b12d96f43834febea21e0b39f6a
Comment 2 raal 2017-08-16 17:52:31 UTC
This seems to have begun at the below commit.
Adding Cc: to Jan-Marek Glogowski; Could you possibly take a look at this one? Thanks
 d90fb57128cdedb3b9535221cbf2e5f0a947e8a0 is the first bad commit
commit d90fb57128cdedb3b9535221cbf2e5f0a947e8a0
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Feb 23 12:05:52 2017 -0800

    source sha:0b08eacd79a2133a07410dfb99bcc04bb9dd2199

author	Jan-Marek Glogowski <glogow@fbihome.de>	2017-02-22 16:08:25 (GMT)
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2017-02-22 16:39:44 (GMT)
commit 0b08eacd79a2133a07410dfb99bcc04bb9dd2199 (patch)
tree 7d27cd1c6874f81999c60d284f4069c1d8706888
parent 6a141837a7bc75a7ef4a7827256be5a3a0a6092d (diff)
tdf#104482 Force updating progress bar on safe
Comment 3 Xisco Faulí 2017-08-16 17:54:30 UTC
In comment 1 I was wrong. that's only happening in gtk3.
the following problem:

1. Open the document
2. Click on start
3. Click on set value 100
4. Click on set value 50

-> Progress bar is set to 100 ( the previous status )

is introduced by 0b08eacd79a2133a07410dfb99bcc04bb9dd2199, which is the same commit as in bug 106281
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 106281 ***