Bug 112063 - Dialog Basic Macro Organizer→Export→Export as Extension → file selection dialog blocked
Summary: Dialog Basic Macro Organizer→Export→Export as Extension → file selection dial...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.2
Keywords: accessibility
Depends on:
Blocks:
 
Reported: 2017-08-27 21:11 UTC by Christoph
Modified: 2017-10-05 07:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test library containing one line Basic with a MsgBox (1.25 KB, application/vnd.openofficeorg.extension)
2017-08-30 18:55 UTC, Christoph
Details
bt with debug symbols (20.64 KB, text/plain)
2017-08-30 20:17 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph 2017-08-27 21:11:51 UTC
File selection dialog is blocked for key and mouse input.
System Linux Mageia 6, Desktop KDE
Reproduced on two machines
To reproduce:
menu Tools → Macros → Organize Macros → LibreOffice Basic → Press Button "Organizer" → Select Tab "Libraries" → Press Button "Export" after having selected a suitable library for export (not Standard!) → Choose option "Export as extension" → file selection dialog pops up but accepts no input. Same happens when you choose "Export as BASIC library".

Workaround: Press key ESCAPE once. As a result the blocking of the dialog is removed and everything works normal. 

Looks like a glitch in the dialog construction. I wonder wether it is a problem of Mageia/KDE. Should be tested for reproduction on an other desktop environment, but I have none.
Comment 1 Julien Nabet 2017-08-29 16:49:26 UTC
Would it be possible you attach a file with a lib?
(have in mind that any attachment is automatically made public so remove any private/confidential part from it).
Comment 2 Julien Nabet 2017-08-30 07:30:49 UTC
About your question from your email, you told "after having selected a suitable library for export (not Standard!)". I got only "Standard" choice so can't reproduce your problem.
Could you attach an example file so we can try to reproduce this?

Please don't respond me on private but directly on the bugtracker by using this link:
https://bugs.documentfoundation.org/show_bug.cgi?id=112063#
Comment 3 Xisco Faulí 2017-08-30 17:08:48 UTC
Setting to NEEDINFO as per comment 2
Comment 4 Christoph 2017-08-30 18:55:57 UTC
Created attachment 135879 [details]
Test library containing one line Basic with a MsgBox

Here is a library in the form of an extension Library1.oxt.
It contains only one line but that is enough for testing. I can confirm the case by having created and exported it.
Comment 5 Julien Nabet 2017-08-30 19:52:09 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this only with gtk3 rendering, not with gtk, kde4 or gen.

I noticed this log on console:
warn:vcl:13885:1:vcl/source/window/winproc.cxx:836: ImplHandleKey: Keyboard-Input is sent to a frame without focus
Comment 6 Julien Nabet 2017-08-30 20:17:17 UTC
Created attachment 135885 [details]
bt with debug symbols
Comment 7 Julien Nabet 2017-08-30 20:18:47 UTC
Caolán: thought you might be interested in this one. Contrary to the reporter, I only reproduce this with gtk3 rendering but I must recognize I use master sources not 5.3.4
Comment 8 Commit Notification 2017-09-01 09:50:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=69c1e6c5489a4709ae4a1db43673e879eb31919c

Resolves: tdf#112063 ensure closing dialog is not parent for file dialog

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-09-01 22:33:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e66c9aa362c1e8729d76090023960610321b14f3

Related: tdf#112063 unsetting and resetting gtk modality is a problem

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2017-09-04 08:55:02 UTC
This works for me now as far as I can see
Comment 11 Commit Notification 2017-09-05 15:15:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74d1296ff968f3571080120297764dac554f4b23&h=libreoffice-5-4

Resolves: tdf#112063 ensure closing dialog is not parent for file dialog

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Julien Nabet 2017-09-05 19:22:01 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.
=> VERIFIED.

Thank you Caolán!
Comment 13 Commit Notification 2017-10-05 07:52:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f561531b69ae4870eaa9648f7c104cabcd0a7fa0

Related: tdf#112063 validation dialog legitimally changes modality

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.