Bug 112107 - searching a term with a space in offline help run in an infinite loop
Summary: searching a term with a space in offline help run in an infinite loop
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss, haveBacktrace
Depends on:
Blocks: Help-Viewer
  Show dependency treegraph
 
Reported: 2017-08-30 13:36 UTC by Rpnpif
Modified: 2019-05-19 08:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (8.06 KB, text/plain)
2017-09-12 18:55 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rpnpif 2017-08-30 13:36:13 UTC
Open the help of LibreOffice.
Search the term "nom de la feuille" (with the quotes) or other term with space and quotes in the search tab.
Libreoffice run in an infinite loop. Only a Libreoffice kill command stop this loop.

It is critical because data could be lost.

All works fine without the quotes.

Expected:
LO should answer "not found" or the name of the page that contained the terms without the quoted.

Yes, the quotes are not needed but the looping behaviour is a bug.
Comment 1 Jean-Baptiste Faure 2017-09-03 17:07:17 UTC
Thank you very much for this bug report !

I reproduce the infinite loop with LO 5.4.1 from Ubuntu PPA and with current master built at home under Ubuntu 16.04 x86-64.

Indeed, as the only way to regain control on the program, is to kill it, not saved changes will be lost. So possible data loss -> critical.

Best regards. JBF
Comment 2 Julien Nabet 2017-09-12 18:55:06 UTC
Created attachment 136208 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today + enable-dbgutil, I got a crash.
I attached bt with symbols.
Comment 3 QA Administrators 2019-05-19 02:50:56 UTC Comment hidden (obsolete)
Comment 4 Rpnpif 2019-05-19 08:31:17 UTC
The Help module works for me now with my browser Firefox, but always offline.
So now, it is not Libreoffice (6.1.6) that is managing the help.

So this issue became invalid for me.