Bug Hunting Session
Bug 112158 - Text anti-aliasing rendering is broken since version 5.3
Summary: Text anti-aliasing rendering is broken since version 5.3
Status: RESOLVED DUPLICATE of bug 107521
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-01 11:43 UTC by Petr Vones
Modified: 2017-09-10 12:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
System anti-aliasing rendering, the expected one (4.24 KB, image/png)
2017-09-01 11:44 UTC, Petr Vones
Details
LibreOffice broken text anti-aliasing rendering (7.77 KB, image/png)
2017-09-01 11:45 UTC, Petr Vones
Details
Screenshot from Win 10 (30.79 KB, image/png)
2017-09-10 09:55 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Vones 2017-09-01 11:43:30 UTC
Description:
Text anti-aliasing rendering is broken since version 5.3 (including 5.4) on Windows 7 x64 and HD3000 GPU. There were no issues in 5.2 and older. OpenGL rendering is disabled, the issue is the same regardless of Use anti-aliasing and Use hardware acceleration checkboxes are checked or not.

It is not consistent with system anti-aliasing rendering anymore.

Steps to Reproduce:
1. Install version 5.2 or older and check the text rendering. It is similar to system one.
2. Install version 5.3 or newer and check the text rendering. 


Actual Results:  
Version 5.3 and newer has broken text-aliasing rendering.

Expected Results:
Text-aliasing rendering should be consistent with system one.


Reproducible: Always

User Profile Reset: Even reinstall.

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Petr Vones 2017-09-01 11:44:35 UTC
Created attachment 135926 [details]
System anti-aliasing rendering, the expected one

System anti-aliasing rendering, the expected one.
Comment 2 Petr Vones 2017-09-01 11:45:33 UTC
Created attachment 135927 [details]
LibreOffice broken text anti-aliasing rendering

LibreOffice broken text anti-aliasing rendering screenshot
Comment 3 Jean-Baptiste Faure 2017-09-01 20:27:21 UTC
Is it better if you disable OpenGL for all rendering: menu Tools > Option > LibreOffice > View.

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 4 Petr Vones 2017-09-01 22:04:30 UTC
(In reply to Jean-Baptiste Faure from comment #3)
> Is it better if you disable OpenGL for all rendering: menu Tools > Option >
> LibreOffice > View.

No, it makes no difference.
Comment 5 Buovjaga 2017-09-10 09:55:49 UTC
Created attachment 136147 [details]
Screenshot from Win 10

It seems OK on Win 10. I don't think the fonts LibO & Notepad use are the same..

Version: 6.0.0.0.alpha0+ (x64)
Build ID: 4b4ebb15456af443347679a7e7e8726c090a5bf5
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2017-08-31_02:04:11
Locale: fi-FI (fi_FI); Calc: group
Comment 6 Petr Vones 2017-09-10 10:01:18 UTC
(In reply to Buovjaga from comment #5)
I don't think the fonts LibO & Notepad use are the
> same..

It is system font, it must be the same as it was in versions 5.2 and older. I can see the same bug in Windows 10 and Windows 2016 as well running as VirtualBox guest (no 3D). Again, it used to be ok there.
Comment 7 Buovjaga 2017-09-10 12:54:33 UTC

*** This bug has been marked as a duplicate of bug 107521 ***