Bug Hunting Session
Bug 112160 - Split sections inside tables: content is moved to unexpected next page
Summary: Split sections inside tables: content is moved to unexpected next page
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-01 16:08 UTC by Miklos Vajna
Modified: 2017-09-04 12:16 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Reproducer document. (8.77 KB, application/vnd.oasis.opendocument.text-flat-xml)
2017-09-01 16:08 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2017-09-01 16:08:15 UTC
Created attachment 135932 [details]
Reproducer document.

Steps to reproduce:

1) Open the attached bugdoc.
2) Move your cursor to the end of the Table1.A2 cell.
3) Press enter.

Expected: Table1.D2 stays on page 1.
Actual: Table1.D2 is moved to page 2.

Seems to be a regression from f8a76d218305a56d15b82b9dac4fafa558872780.
Comment 1 Commit Notification 2017-09-04 12:00:23 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ec262cbc56822d8fffccd6e983848df196cf5c44

tdf#112160 sw: audit GetNextLayoutLeaf() calls in SwFrame::GetNextSctLeaf()

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.