Bug 112174 - Limit the maximum accepted length of input in the font name field (see comment 4)
Summary: Limit the maximum accepted length of input in the font name field (see commen...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Name-Combobox
  Show dependency treegraph
 
Reported: 2017-09-02 07:40 UTC by Emil Tanev
Modified: 2021-07-03 05:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Tanev 2017-09-02 07:40:50 UTC
Open an odt document of about 58000 words
Select all and Copy
Paste it in the Font name field
Hit Enter

Issue: The application stalls indefinately, default style dropdown disappears

https://www.screencast.com/t/dTERCFuTgBT

OS Intel Core i7, 2.60 GHz, RAM 8 GB
Comment 1 Emil Tanev 2017-09-02 07:45:28 UTC
Reproducible in the Style dropdown, however Font size field handles this gracefully.
Comment 2 Jean-Baptiste Faure 2017-09-03 07:16:46 UTC
I do not reproduce with current master built at home under Ubuntu 16.04 x86-64.
I tried with the document LICENSE.fodt locally saved as .odt. This text 65156 words and 403909 characters.

Not reproducible with LO 5.4.1 from Ubuntu PPA.

Perhaps a Windows only problem.

Best regards. JBF
Comment 3 Dieter 2017-09-04 08:45:29 UTC
Also for me not reproducible with LO 5.3.6.1 (x64 and Win10). I had a document with almost 56.000 words. LO needed some time, but finally it worked.
Comment 4 Buovjaga 2017-09-09 17:53:57 UTC
I used Varney the Vampire, which is 200k words: http://www.gutenberg.org/cache/epub/14833/pg14833.txt
Took maybe a minute, but worked.

Perhaps there should be some sane maximum string length, though..

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: a27eb931c22313d4dd5c73b35358c0532d20b79e
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 8th 2017
Comment 5 Buovjaga 2017-09-11 12:07:01 UTC
(In reply to Buovjaga from comment #4)
> Perhaps there should be some sane maximum string length, though..

Cloph had the idea that disallowing paragraph breaks could also work.
Comment 6 QA Administrators 2018-09-12 02:37:31 UTC Comment hidden (obsolete)
Comment 7 Dieter 2018-09-12 07:11:09 UTC
Tried with the text from comment 4. Took about 2 minutes, but finally it worked. I really couldn't see in the history, that somebody was able to reproduce the original bug report. Buovjaga changed the bug summary, but I think, now it is more an enhancement.
Comment 8 Buovjaga 2018-09-12 07:40:23 UTC
No, I think it can be seen as a bug - we are trying to avoid annoying and disrupting behaviour here.
Comment 9 QA Administrators 2019-09-13 02:50:47 UTC
Dear Emil Tanev,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug