Bug 112232 - New document window is incorrectly positioned on application launch
Summary: New document window is incorrectly positioned on application launch
Status: RESOLVED DUPLICATE of bug 75644
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-05 13:55 UTC by Elliotte Rusty Harold
Modified: 2017-09-05 15:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (206.78 KB, image/png)
2017-09-05 13:55 UTC, Elliotte Rusty Harold
Details
new document window (155.57 KB, image/png)
2017-09-05 13:56 UTC, Elliotte Rusty Harold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elliotte Rusty Harold 2017-09-05 13:55:07 UTC
Description:
See screenshot. On launch, the window comes up centered. It shouldn't per Mac OS X guidelines (and likely other platforms as well).

It should be positioned at the left edge of the screen immediately below the menu bar. Furthermore it should, at least on small screens like 13" laptops, be maximized.

FYI Microsoft Word gets this right. 

Steps to Reproduce:
1. Launch LibreOffice


Actual Results:  
centered, not maximized

Expected Results:
not centered, maximimzed


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
Comment 1 Elliotte Rusty Harold 2017-09-05 13:55:47 UTC
Created attachment 136029 [details]
screenshot
Comment 2 Elliotte Rusty Harold 2017-09-05 13:56:06 UTC
Created attachment 136030 [details]
new document window
Comment 3 Jean-Baptiste Faure 2017-09-05 14:35:10 UTC
(In reply to Elliotte Rusty Harold from comment #0)
> Description:
> See screenshot. On launch, the window comes up centered. It shouldn't per
> Mac OS X guidelines (and likely other platforms as well).
> 
> It should be positioned at the left edge of the screen immediately below the
> menu bar. Furthermore it should, at least on small screens like 13" laptops,
> be maximized.

Strange ideas. Wrong in Linux case.

Best regards. JBF
Comment 4 Alex Thurgood 2017-09-05 15:45:06 UTC
@Elliotte : Unfortunately, LibreOffice is still quite far from being a nicely behaved macOS application. There is a certain reticence (and lack of coders) to make LibreOffice more OSX-like, one of the reasons being put forward is that LibreOffice is provided for multiple OSes and multiple desktop paradigms, which makes deciding on the best course of action hard(er) as there aren't enough Mac coders to be able to develop and support (moving forward) a fully OSX-ified version of LibreOffice. As a result, LO for Mac plays second fiddle to design choices that are made mainly with the Linux desktop environments in mind, unless of course you happen to also have Windows, for which LO generally shows better system integration (more developers being paid through support contracts to sort out issues on Windows machines).  

The issue of startup window placement and subsequent document opening window dimensions is known from bug 75644.

*** This bug has been marked as a duplicate of bug 75644 ***