Bug 112289 - FILESAVE: File save fails because a certificate is needed for saving (MacOS)
Summary: FILESAVE: File save fails because a certificate is needed for saving (MacOS)
Status: RESOLVED DUPLICATE of bug 112288
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-08 10:27 UTC by Telesto
Modified: 2017-09-08 22:41 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-09-08 10:27:15 UTC
Description:
File save fails because a certificate is needed for saving (MacOS)

Steps to Reproduce:
1. Open a Writer document
2. Press CMD+S
3. Type a file name
4. Press save
5. Select a certificate screen

Actual Results:  
Can't save because a certificate seems to be required


Expected Results:
Saving should be possible


Reproducible: Always

User Profile Reset: YES

Additional Info:
Version: 6.0.0.0.alpha0+
Build ID: 84e1f8567fa0a2b83323d8944307d1db7a5b45f5
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-09-06_10:01:15
Locale: nl-NL (nl_NL.UTF-8); Calc: group



User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Alex Thurgood 2017-09-08 15:46:28 UTC
Confirming with :

Version: 6.0.0.0.alpha0+
Build ID: a27eb931c22313d4dd5c73b35358c0532d20b79e
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 2 Alex Thurgood 2017-09-08 15:47:14 UTC

*** This bug has been marked as a duplicate of bug 112288 ***
Comment 3 Commit Notification 2017-09-08 22:41:55 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3fa8ff7734541c8cb12a5e80b6770cbc7a9347f1

tdf#112289 OSX fpicker: don't default to true

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.