Bug Hunting Session
Bug 112305 - Text is invisible, both in UI and in editor, AMD R5 and R7 drivers Windows 10
Summary: Text is invisible, both in UI and in editor, AMD R5 and R7 drivers Windows 10
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.2.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 113270 116433 116500 (view as bug list)
Depends on: 107166
Blocks: DirectWrite DirectWrite-Regression
  Show dependency treegraph
 
Reported: 2017-09-09 22:14 UTC by Terje Bråten
Modified: 2018-03-19 20:23 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot of build 2017-09-09 showing the problem (1.33 MB, image/png)
2017-09-10 00:00 UTC, Terje Bråten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terje Bråten 2017-09-09 22:14:58 UTC
Description:
No text is displayed in the UI, only horizontal lines where the text is supposed to be. This applies to all text, menu items and text that you type yourself in word, and text in dialog boxes etc.

This is a continuation of bug #107166 for issues that was not resolved with that bug.

Steps to Reproduce:
1. Install Libereoffice
2. Start libreoffice


Actual Results:  
You see "underscore" lines instead of text. No readable text on the screen.

Expected Results:
Be able to see normal text in the application.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Terje Bråten 2017-09-09 22:36:21 UTC
I just now tried to run the latest installer
https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/libo-master64~2017-09-09_02.18.42_LibreOfficeDev_6.0.0.0.alpha0_Win_x64.msi

but I was not able to run that. The installer just hangs after a few seconds.

Terje B.
Comment 2 Terje Bråten 2017-09-09 23:52:07 UTC
Ok, was able to install libo-master64~2017-09-09_02.18.42_LibreOfficeDev_6.0.0.0.alpha0_Win_x64.msi after all, my computer just needed a reboot.

Still the same bug, and empty log file when I try to run it in cygwin with the environment SAL_LOG=1
Comment 3 Terje Bråten 2017-09-10 00:00:32 UTC
Created attachment 136141 [details]
Screen shot of build 2017-09-09 showing the problem
Comment 4 V Stuart Foote 2017-09-10 02:51:17 UTC
@Terje,

OK, so just to confirm--you are still working with an HP Windows 10 system, with dual R7/R5 iGPU/dGPU.  Is the ref below still the system configuration (from msinfo32.exe run)?

Also, have you been able to toggle LibreOffice runs to "low power" to run on the integrated R7 GPU, as we as in "high performance" to run on the dedicated R5 GPU?

=-ref-=

Version	10.0.15063 Build 15063
Other OS Description 	Not Available
OS Manufacturer	Microsoft Corporation
System Name	BRATEN01
System Manufacturer	HP
System Model	HP Pavilion Desktop PC 570-p0xx
System Type	x64-based PC
System SKU	Z7C73EA#ABU
Processor	AMD A10-9700 RADEON R7, 10 COMPUTE CORES 4C+6G, 3500 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date	AMI F.02, 17/01/2017

Graphics display:
Name	AMD Radeon R7 Graphics + R5 435 Dual Graphics
PNP Device ID	PCI\VEN_1002&DEV_9874&SUBSYS_835C103C&REV_E2\3&11583659&1&08
Adapter Type	AMD Radeon Graphics Processor (0x9874), Advanced Micro Devices, Inc. compatible
Adapter Description	AMD Radeon R7 Graphics + R5 435 Dual Graphics
Adapter RAM	512.00 MB (536,870,912 bytes)
Installed Drivers	aticfx64.dll,aticfx64.dll,aticfx64.dll,amdxc64,aticfx32,aticfx32,aticfx32,amdxc32,atiumd64,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64
Driver Version	21.19.142.32768
INF File	oem24.inf (ati2mtag_CarrizoDS section)
Colour Planes	Not Available
Colour Table Entries	4294967296
Resolution	1920 x 1080 x 60 hertz

Name	AMD Radeon R5 435
PNP Device ID	PCI\VEN_1002&DEV_6665&SUBSYS_34001462&REV_C3\4&27C1BE9B&0&0019
Adapter Type	AMD Radeon Graphics Processor (0x6665), Advanced Micro Devices, Inc. compatible
Adapter Description	AMD Radeon R5 435
Adapter RAM	(2,147,483,648) bytes
Installed Drivers	aticfx64.dll,aticfx64.dll,aticfx64.dll,amdxc64,aticfx32,aticfx32,aticfx32,amdxc32,atiumd64,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64
Driver Version	21.19.142.32768
INF File	oem24.inf (ati2mtag_R503DS section)
Colour Planes	Not Available
Colour Table Entries	4294967296
Resolution	1920 x 1080 x 60 hertz
Comment 5 V Stuart Foote 2017-09-10 03:09:54 UTC
(In reply to V Stuart Foote from comment #4)
> OK, so just to confirm--you are still working with an HP Windows 10 system,
> with dual R7/R5 iGPU/dGPU.  Is the ref below still the system configuration
> (from msinfo32.exe run)?
> 

Oops you'd posted an updated spec in bug 107166#146, same system A10 based R7 iGPU/R5 dGPU--with updated AMD drivers:

=-ref-=
from #146 tdf#107166

Name	AMD Radeon R7 Graphics + R5 435 Dual Graphics
PNP Device ID	PCI\VEN_1002&DEV_9874&SUBSYS_835C103C&REV_E2\3&11583659&1&08
Adapter Type	AMD Radeon Graphics Processor (0x9874), Advanced Micro Devices, Inc. compatible
Adapter Description	AMD Radeon R7 Graphics + R5 435 Dual Graphics
Adapter RAM	512.00 MB (536,870,912 bytes)
Installed Drivers	aticfx64.dll,aticfx64.dll,aticfx64.dll,amdxc64.dll,aticfx32,aticfx32,aticfx32,amdxc32,atiumd64,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64
Driver Version	21.19.512.12
INF File	oem24.inf (ati2mtag_CarrizoDS section)
Colour Planes	Not Available
Colour Table Entries	4294967296
Resolution	1920 x 1080 x 60 hertz
Bits/Pixel	32
Memory Address	0xD0000000-0xFEC2FFFF
Memory Address	0xF0000000-0xF07FFFFF
I/O Port	0x0000F000-0x0000F0FF
Memory Address	0xFEB00000-0xFEB3FFFF
IRQ Channel	IRQ 4294967284
Driver	c:\windows\system32\driverstore\filerepository\c0311291.inf_amd64_89545f50ccbd636d\atikmpag.sys (21.19.512.12, 512.90 KB (525,208 bytes), 15/02/2017 05:48)
	
Name	AMD Radeon R5 435
PNP Device ID	PCI\VEN_1002&DEV_6665&SUBSYS_34001462&REV_C3\4&27C1BE9B&0&0019
Adapter Type	AMD Radeon Graphics Processor (0x6665), Advanced Micro Devices, Inc. compatible
Adapter Description	AMD Radeon R5 435
Adapter RAM	(2,147,483,648) bytes
Installed Drivers	aticfx64.dll,aticfx64.dll,aticfx64.dll,amdxc64.dll,aticfx32,aticfx32,aticfx32,amdxc32,atiumd64,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64
Driver Version	21.19.512.12
INF File	oem24.inf (ati2mtag_R503DS section)
Colour Planes	Not Available
Colour Table Entries	4294967296
Resolution	1920 x 1080 x 60 hertz
Bits/Pixel	32
Memory Address	0xE0000000-0xEFFFFFFF
Memory Address	0xFEA00000-0xFEA3FFFF
I/O Port	0x0000DF00-0x0000DFFF
IRQ Channel	IRQ 4294967273
Driver	c:\windows\system32\driverstore\filerepository\c0311291.inf_amd64_89545f50ccbd636d\atikmpag.sys (21.19.512.12, 512.90 KB (525,208 bytes), 15/02/2017 05:48)
Comment 6 Mike Kaganski 2017-09-11 05:13:44 UTC
AFAIK, (personally I don't suffer from this, but I was told by those who do) the safe mode wizard dialog also suffers from this problem.

I suppose that a new issue needs to be filed with regards to improving the Safe Mode dialog so that it (1) should launch safely with regards of this issue, and (2) should provide an option to run LO with required settings to workaround this problem. As I cannot prove that I'm correct, I ask someone who can to do that.
Comment 7 V Stuart Foote 2017-09-11 06:15:30 UTC
(In reply to Mike Kaganski from comment #6)
> ... improving the
> Safe Mode dialog so that it (1) should launch safely with regards of this
> issue, and (2) should provide an option to run LO with required settings to
> workaround this problem.

Not sure it is appropriate, or even feasible, to be handled in Safe Mode. Especially if the failure is AMD hardware driver related for rendering DirectX DirectWrite Direct2D text. Any Safe Mode work would have to signal the OS to force non-accelerated CPU rendering, or alternatively force OpenGL rendering.

And this really seems a corner case for users afflicted with AMD GPUs and balky DirectX and OpenGL drivers--it is not common.

Seems, if we can't get Direct2D rendering, then maybe forcing OpenGL rendering for these modern R5/R7 AMD GPUs might be a better approach. May require we figure out how to signal the OS to force AMD config to use OpenGL and force a "high performance" rendering assignment for LibreOffice. That might not need to be a Safe Mode fall back, and could be done as a "white listing" as part of the OpenGL validation checks.

Very real issue is that we can't find reliable hardware configuration to reproduce for WinDbg trace.
Comment 8 Mike Kaganski 2017-09-11 07:06:38 UTC Comment hidden (off-topic)
Comment 9 Terje Bråten 2017-09-11 09:09:07 UTC
(In reply to V Stuart Foote from comment #4)
> @Terje,
> 
> OK, so just to confirm--you are still working with an HP Windows 10 system,
> with dual R7/R5 iGPU/dGPU.  Is the ref below still the system configuration
> (from msinfo32.exe run)?
Yes, you got my spec right in comment #5.

> 
> Also, have you been able to toggle LibreOffice runs to "low power" to run on
> the integrated R7 GPU, as we as in "high performance" to run on the
> dedicated R5 GPU?
> 

I am sorry, you have lost me here. I do not know how to do this. May be if someone could give me a guide on how to find this toggle?

TB
Comment 10 Terje Bråten 2017-09-11 09:11:58 UTC
(In reply to Mike Kaganski from comment #6)
> AFAIK, (personally I don't suffer from this, but I was told by those who do)
> the safe mode wizard dialog also suffers from this problem.
> 

What is the safe mode wizard, and how can I try that?
Comment 11 V Stuart Foote 2017-09-11 17:56:43 UTC
(In reply to Terje Bråten from comment #9)
 
> I am sorry, you have lost me here. I do not know how to do this. May be if
> someone could give me a guide on how to find this toggle?
> 

This technical guide from AMD is for Laptops, but believe its GUI descriptions would apply to your HP Pavilion Desktop PC 570-p0xx with the Crimson 17.7.2

https://community.amd.com/docs/DOC-1581

While these are more general Windows 10 coverage for AMD APU iGPU, and dGPU

https://community.amd.com/docs/DOC-1312
https://community.amd.com/docs/DOC-1313(

In reply to Terje Bråten from comment #10)
> What is the safe mode wizard, and how can I try that?

Launch from Help -> Restart in Safe Mode

All this does now is to launch LibreOffice using new temporary user profile with LibreOffice defaults, it by-passes any installed extensions and any user configurations or customization of the user's current profile.  

Essentially starting with a clean slate for testing without having to delete what may otherwise be a functional profile.
Comment 12 Terje Bråten 2017-09-12 20:04:49 UTC
Here is my latest updated graphics drivers (still same problem):

Name	AMD Radeon R7 Graphics + R5 M435 Dual Graphics
PNP Device ID	PCI\VEN_1002&DEV_9874&SUBSYS_835C103C&REV_E2\3&11583659&1&08
Adapter Type	AMD Radeon Graphics Processor (0x9874), Advanced Micro Devices, Inc. compatible
Adapter Description	AMD Radeon R7 Graphics + R5 M435 Dual Graphics
Adapter RAM	512.00 MB (536,870,912 bytes)
Installed Drivers	aticfx64.dll,aticfx64.dll,aticfx64.dll,amdxc64.dll,aticfx32,aticfx32,aticfx32,amdxc32,atiumd64,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64
Driver Version	22.19.662.4
INF File	oem69.inf (ati2mtag_CarrizoDS section)
Colour Planes	Not Available
Colour Table Entries	4294967296
Resolution	1920 x 1080 x 60 hertz
Bits/Pixel	32
Memory Address	0xD0000000-0xFEC2FFFF
Memory Address	0xF0000000-0xF07FFFFF
I/O Port	0x0000F000-0x0000F0FF
Memory Address	0xFEB00000-0xFEB3FFFF
IRQ Channel	IRQ 4294967284
Driver	c:\windows\system32\driverstore\filerepository\c0316467.inf_amd64_3d8fbd78102e53d7\atikmpag.sys (22.19.662.4, 536.91 KB (549,800 bytes), 27/07/2017 00:05)
	
Name	AMD Radeon R5 M435
PNP Device ID	PCI\VEN_1002&DEV_6665&SUBSYS_34001462&REV_C3\4&27C1BE9B&0&0019
Adapter Type	AMD Radeon Graphics Processor (0x6665), Advanced Micro Devices, Inc. compatible
Adapter Description	AMD Radeon R5 M435
Adapter RAM	(2,147,483,648) bytes
Installed Drivers	aticfx64.dll,aticfx64.dll,aticfx64.dll,amdxc64.dll,aticfx32,aticfx32,aticfx32,amdxc32,atiumd64,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64
Driver Version	22.19.662.4
INF File	oem69.inf (ati2mtag_R503DS section)
Colour Planes	Not Available
Colour Table Entries	4294967296
Resolution	1920 x 1080 x 60 hertz
Bits/Pixel	32
Memory Address	0xE0000000-0xEFFFFFFF
Memory Address	0xFEA00000-0xFEA3FFFF
I/O Port	0x0000DF00-0x0000DFFF
IRQ Channel	IRQ 4294967273
Driver	c:\windows\system32\driverstore\filerepository\c0316467.inf_amd64_3d8fbd78102e53d7\atikmpag.sys (22.19.662.4, 536.91 KB (549,800 bytes), 27/07/2017 00:05)
Comment 13 Terje Bråten 2017-09-12 20:16:23 UTC
(In reply to V Stuart Foote from comment #4)
> Also, have you been able to toggle LibreOffice runs to "low power" to run on
> the integrated R7 GPU, as we as in "high performance" to run on the
> dedicated R5 GPU?
> 

Yes that did make a difference!

When the setting is on "Power Saving" then I can see all the text, as it should be.
When the setting is on "High Performance" then all text is just "underscore" lines.
Comment 14 M. 2017-10-03 10:24:35 UTC
Text in menues first disappeared when updating to 5.3.2.
5.3.1 still worked fine, roll back to 5.3.1. made the menue texts to show again.
5.3.3. still has the same bug as 5.3.2.
Not solved neither with 5.4.0. nor 5.4.1.. 
Last one that works is still 5.3.1.2

HP Probook 4540s
Microsoft Windows 10 Professional (x64) Build 15063.296 (Latest)
Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
Intel(R) HD Graphics 3000 (driver ver. 9.17.10.4459)
AMD Radeon HD 7650M (driver ver. 15.201.1301.0)
4GB Ram
Comment 15 Xisco Faulí 2017-10-03 10:31:10 UTC
Hi *,
Could someone check if the problem is still reproducible with this daily build for LibreOffice 5.3.7 http://dev-builds.libreoffice.org/daily/libreoffice-5-3/Win-x86@62-TDF/current/ ? While testing, please try with OpenGL enabled and disabled. Thank you very much.
Comment 16 V Stuart Foote 2017-10-03 14:26:50 UTC
(In reply to M. from comment #14)
> Text in menues first disappeared when updating to 5.3.2.
> 5.3.1 still worked fine, roll back to 5.3.1. made the menue texts to show
> again.
> 5.3.3. still has the same bug as 5.3.2.
> Not solved neither with 5.4.0. nor 5.4.1.. 
> Last one that works is still 5.3.1.2
> 
> HP Probook 4540s
> Microsoft Windows 10 Professional (x64) Build 15063.296 (Latest)
> Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
> Intel(R) HD Graphics 3000 (driver ver. 9.17.10.4459)
> AMD Radeon HD 7650M (driver ver. 15.201.1301.0)
> 4GB Ram

Came up a few times in the earlier thread notably https://bugs.documentfoundation.org/show_bug.cgi?id=107166#c97

Your laptop operates in either dynamic (automatic switching) or fixed mode as set from BIOS. And then you choose which GPU handles which program [1][2]

Changes from AMD & HP as they moved the Catalyst drivers and interface forward. Windows driver updates pick up some of the driver changes, but not necessarily the best.

=-ref-=
[1] https://support.hp.com/us-en/document/c03048374

[2] https://community.amd.com/docs/DOC-1581
Comment 17 kankra 2017-10-07 14:08:48 UTC
Reply to comment #14

Just tested libreoffice-5-3~2017-10-06_21.44.02_LibreOfficeDev_5.3.8.0.0_Win_x86. Good news, works for me!

LibreOffice_5.4.2_Win_x64 showed the notorious lack of characters in menues and docs.

OS: Windows 10 Home 64 Bit Version 1703 Build 15063.608
HW: acer ASPIRE 1825PTZ, intel SU4100, intel GMA 4500MHD
Graphics Driver Version 8.15.10.1892

Thank you, Xisco Faulí!

Thomas
Comment 18 Lars 2017-10-08 12:44:10 UTC
.. the same issue on

Microsoft Windows 7 Home Premium
6.1.7601 Service Pack 1 Build 7601
LENOVO 0880
X86-basierter PC
Prozessor    Pentium(R) Dual-Core CPU       T4400  @ 2.20GHz, 2200 MHz, 2 Kern(e), 2 logische(r) Prozessor(en)
BIOS-Version/-Datum    LENOVO 18CN42WW(V2.51), 18.01.2010
SMBIOS-Version    2.5

Name    Mobile Intel(R) 4 Series Express Chipset Family
PNP-Gerätekennung PCI\VEN_8086&DEV_2A42&SUBSYS_3A0217AA&REV_09\3&11583659&2&10
Adaptertyp    Mobile Intel(R) 4 Series Express Chipset Family, Intel Corporation-kompatibel
Adapterbeschreibung    Mobile Intel(R) 4 Series Express Chipset Family
Adapter-RAM    780,30 MB (818.204.672 Bytes)
Installierte Treiber igdumdx32.dll,igd10umd32.dll,igd10umd32.dll
Treiberversion    8.15.10.1840
INF-Datei    oem5.inf (Abschnitt iCNT0)
Farbebenen    Nicht verfügbar
Farbtabelleneinträge    4294967296
Auflösung    1366 x 768 x 60 Hz
Bits/Pixel    32
Speicheradresse    0xF4000000-0xF43FFFFF
Speicheradresse    0xD0000000-0xDFFFFFFF
E/A-Port    0x00001800-0x00001807
IRQ-Kanal    IRQ 4294967294
E/A-Port    0x000003B0-0x000003BB
E/A-Port    0x000003C0-0x000003DF
Speicheradresse    0xA0000-0xBFFFF
Treiber    c:\windows\system32\drivers\igdkmd32.sys (8.15.10.1840, 5,65 MB (5.922.816 Bytes), 22.03.2010 09:29)

HTH
Comment 19 kankra 2017-10-09 08:28:22 UTC
Lars,

please consider testing of libreoffice dev build provided by Xisco Faulí, see comment 15.

I have Intel Graphics Driver (igd) Version 8.15.10, too. The dev build brought back the characters in the menue and the docs.

Please support Xisco Faulí, debugging. Thank you.

Thomas
Comment 20 kankra 2017-10-09 08:35:02 UTC
Xisco Faulí,

the Intel Graphics Driver for Windows 10 doesn't support OpenGL no more. So I'm not able to test with OpenGL active, sorry.

Thomas
Comment 21 Terje Bråten 2017-10-10 19:39:29 UTC
(In reply to Xisco Faulí from comment #15)
> Hi *,
> Could someone check if the problem is still reproducible with this daily
> build for LibreOffice 5.3.7
> http://dev-builds.libreoffice.org/daily/libreoffice-5-3/Win-x86@62-TDF/
> current/ ? While testing, please try with OpenGL enabled and disabled. Thank
> you very much.

Hi I just checked it.

That version of the app fixed it. It works!

I tried with the Radeon card both on "Power Saving" and "High Performance" and it worked in both modes. I also tried with OpenGL (the menu setting says OpenCL) both on and off and it worked in both cases.

Congratulations, it seems like you have finally figured it out.
Comment 22 V Stuart Foote 2017-10-10 20:53:37 UTC
Please be aware that this is not "fixed", rather devs have simply backed out use of DirectX-11 DirectWrite Direct2D rendering and restored the deficient Microsoft GDI based rendering for Windows.  OpenGL rendering continues to use DirectWrite Direct2D based rendering and both modes continue to be impacted by faulty hardware drivers.

If affected in the future check in on bug 112486 and bug 109234
Comment 23 Xisco Faulí 2017-10-19 16:04:02 UTC
*** Bug 113270 has been marked as a duplicate of this bug. ***
Comment 24 Buovjaga 2018-03-17 08:01:41 UTC
*** Bug 116433 has been marked as a duplicate of this bug. ***
Comment 25 V Stuart Foote 2018-03-19 20:23:41 UTC
*** Bug 116500 has been marked as a duplicate of this bug. ***