Bug 112307 - Calc is slower in moving from one sheet to another sheet and scrolling up/down within the sheet
Summary: Calc is slower in moving from one sheet to another sheet and scrolling up/dow...
Status: RESOLVED DUPLICATE of bug 109220
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, regression
Depends on:
Blocks:
 
Reported: 2017-09-10 11:14 UTC by perie_gut
Modified: 2017-09-11 08:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample test file (1.06 MB, application/vnd.ms-excel)
2017-09-10 11:14 UTC, perie_gut
Details

Note You need to log in before you can comment on or make changes to this bug.
Description perie_gut 2017-09-10 11:14:32 UTC
Created attachment 136148 [details]
sample test file

I have attached a sample file for performance evaluation. also, in the file, are the current properties of my libreoffice. In Ms Office 2007 and the latest, the transition from one sheet to another is smooth using my netbook but with libreoffice, it's slower. also scrolling the sheet up and down has a delay.
Comment 1 Buovjaga 2017-09-11 06:32:53 UTC
Looks like it's Windows-only as I can't repro on Linux.

It is faster in 5.3. I will try to bibisect later.

Win 10
Version: 6.0.0.0.alpha0+ (x64)
Build ID: 4b4ebb15456af443347679a7e7e8726c090a5bf5
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2017-08-31_02:04:11
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Buovjaga 2017-09-11 08:51:52 UTC
I bibisected it to the same commit as bug 109220 so closing this..

*** This bug has been marked as a duplicate of bug 109220 ***