Bug 112311 - Crash when opening docx converted from pdf (Linux/MAC)
Summary: Crash when opening docx converted from pdf (Linux/MAC)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: highest critical
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.2 target:5.3.7
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2017-09-10 22:13 UTC by z
Modified: 2017-09-14 16:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb backtrace (51.36 KB, text/plain)
2017-09-11 20:28 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description z 2017-09-10 22:13:44 UTC
Description:
I have a fairly big pdf file that I converted to docx in Adobe Acrobat.
When I then try to open it in LibreOffice it crashes and show me the document recovery screen.

Steps to Reproduce:
1. Open file.


Actual Results:  
Crash

Expected Results:
Opening


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Buovjaga 2017-09-11 06:35:18 UTC
Please attach the docx.

A crash log would also be nice: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Mac_OSX:_How_to_get_debug_information

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 z 2017-09-11 16:07:08 UTC
(In reply to Buovjaga from comment #1)
> Please attach the docx.
> 
> A crash log would also be nice:
> https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Mac_OSX:
> _How_to_get_debug_information
> 
> Set to NEEDINFO.
> Change back to UNCONFIRMED after you have provided the information.


The file is too big to attach here.

I don't get any prompt from the OS.
Just a windows saying "Due to an unexpected error, LibreOffice crashed..."
Is there anyway I can find that crash log?
Comment 3 Buovjaga 2017-09-11 16:19:26 UTC
(In reply to z from comment #2)
> The file is too big to attach here.
> 
> I don't get any prompt from the OS.
> Just a windows saying "Due to an unexpected error, LibreOffice crashed..."
> Is there anyway I can find that crash log?

If you are able to share it publicly, you could upload it to some file host and give us the link.

I guess it does not produce a crash log (I don't have a lot of Mac experience).
Comment 4 z 2017-09-11 18:47:42 UTC
https://ufile.io/v57kb
Comment 5 Xisco Faulí 2017-09-11 19:09:43 UTC
Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: 383aab7ed63bf30931c1cf89138707d2228b5dce
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 6 Xisco Faulí 2017-09-11 19:32:53 UTC
Also reproduced in

- Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

- Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 7 Xisco Faulí 2017-09-11 19:43:28 UTC
Not reproducible in

Version: 6.0.0.0.alpha0+
Build ID: 78960ad06faca055a6d97afbc764c902d5d07f6f
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-08-30_06:31:19
Locale: es-ES (es_ES); Calc: group
Comment 8 Xisco Faulí 2017-09-11 20:28:50 UTC
Created attachment 136181 [details]
gdb backtrace
Comment 9 Michael Stahl 2017-09-13 09:13:37 UTC
fixed on master
Comment 10 Commit Notification 2017-09-13 09:14:10 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88c84e71e2559ec6d0b4f8c5101a149daa4a2b2b

tdf#112311 oox: fix UAF of std::shared_ptr

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-09-13 15:59:25 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=561cf96d8e91adf141d165b818bb2be6e3e97f90&h=libreoffice-5-4

tdf#112311 oox: fix UAF of std::shared_ptr

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2017-09-14 16:00:50 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c7c19d80e6a6327be563a18febc3854d9a38daf&h=libreoffice-5-3

tdf#112311 oox: fix UAF of std::shared_ptr

It will be available in 5.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.