Bug 112347 - GTK2: Document is not displayed/redrawn in full screen after switching workspaces with Marco/Xfwm window manager
Summary: GTK2: Document is not displayed/redrawn in full screen after switching worksp...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Full-Screen-Mode GTK2 Virtual-Desktops
  Show dependency treegraph
 
Reported: 2017-09-12 11:20 UTC by krajcsi
Modified: 2018-02-14 09:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description krajcsi 2017-09-12 11:20:21 UTC
Description:
See summary and steps below.

Steps to Reproduce:
1. Create a Writer document
2. Switch to full screen
3. Switch to another workspace
4- Switch back

Actual Results:  
The screen is gray

Expected Results:
The document should be seen


Reproducible: Always

User Profile Reset: No

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

Version: 5.4.1.2
Build ID: 1:5.4.1~rc2-0ubuntu0.16.04.1~lo0
CPU threads: 4; OS: Linux 4.11; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

I use Mate on Linux Mint.

This bug was not present in the 5.3 versions or earlier.
Builds ID: LibreOffice 5.4.1.2


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.79 Safari/537.36
Comment 1 Jean-Baptiste Faure 2017-09-24 18:02:13 UTC Comment hidden (obsolete)
Comment 2 Jean-Baptiste Faure 2017-09-24 18:06:11 UTC
Not reproducible for me with the same version:
Version: 5.4.1.2
Build ID: 1:5.4.1~rc2-0ubuntu0.16.04.1~lo0
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); Calc: single

Main differences:
- gtk3 VCL backend
- Ubuntu / Unity

Do you reproduce the same behavior if you use gtk3 instead of gtk2 ?
1/ install libreoffice-gtk3 package
2/ start LibreOffice and check Help > About LibreOffice
3/ if you are still using gtk2, you can force gtk3 backend temporarily :
   a/ start a terminal
   b/ type the command export SAL_USE_VCLPLUGIN="gtk3"
   c/ type the command libreoffice

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 3 krajcsi 2017-09-25 06:37:05 UTC
Thanks for the info. I can confirm that the issue is gtk2 specific, with gtk3 it works as expected (at least regarding the disappearing document, otherwise it has some other issues gtk2 version handles correctly).
Comment 4 Jean-Baptiste Faure 2017-09-25 07:36:16 UTC
(In reply to krajcsi from comment #3)
> Thanks for the info. I can confirm that the issue is gtk2 specific, with
> gtk3 it works as expected (at least regarding the disappearing document,
> otherwise it has some other issues gtk2 version handles correctly).

Thank you for your test and answer. Updated summary accordingly.

Best regards. JBF
Comment 5 Xisco Faulí 2017-09-25 08:13:08 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: fb60217569b0fb5bc949c58b054da71992fe2582
CPU threads: 4; OS: Linux 4.10; UI render: GL; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

on Ubuntu 17.04.

Mate only ?
Comment 6 Buovjaga 2017-10-29 19:27:17 UTC
(In reply to Xisco Faulí from comment #5)
> Mate only ?

Jay: you have a Mate system among others, right?
Comment 7 Yousuf Philips (jay) (retired) 2017-10-29 20:21:58 UTC
> (In reply to Buovjaga from comment #6)
> Jay: you have a Mate system among others, right?

Happens in Ubuntu Mate 16.04 with Mate 1.12.1 with 6.0 alpha 1 git build gtk2, but doesn't in Solus 3 with Mate 1.18.0 with the same 6.0 alpha 1 git build or Linux Mint 18 with Mate 1.14.1 with master below.

Version: 6.0.0.0.alpha1+
Build ID: 43d6b11a5c1dda0cc2c1e06c768eece25051a56c
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 8 Buovjaga 2017-10-30 07:24:05 UTC
krajcsi: ok, seems like newer Mate versions have fixed it. Which Mate version are you using and is it possible for you to upgrade?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists with Mate 1.14 or newer. Change to RESOLVED WORKSFORME, if the problem went away with an upgrade.
Comment 9 krajcsi 2017-10-31 11:50:02 UTC
I use MATE 1.18.0 with Linux Mint 18.2

Seems like Mate version in itself does not solve the problem.
Comment 10 Buovjaga 2017-10-31 12:11:44 UTC
(In reply to krajcsi from comment #9)
> I use MATE 1.18.0 with Linux Mint 18.2
> 
> Seems like Mate version in itself does not solve the problem.

Ok, then you could try 6.0 like Jay:
https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/current/
https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 11 krajcsi 2017-10-31 12:26:01 UTC
I tried the version below, and the issue is still there.

Version: 6.0.0.0.alpha1+
Build ID: 60a03d97bc35c02cb1eff0e4a02b6f37fd1a6a34
CPU threads: 4; OS: Linux 4.11; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-10-30_23:05:13
Locale: en-US (en_US.UTF-8); Calc: group
Comment 12 Yousuf Philips (jay) (retired) 2017-10-31 21:08:05 UTC
krajcsi: what graphics card and graphics driver are you running? If you have inxi installed, you can run this command to get this information - 'inxi -G' (without the single quotes).
Comment 13 krajcsi 2017-11-03 18:06:56 UTC
On one of my computers:
Graphics:  Card: Intel Device 5916
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2)
           GLX Version: 3.0 Mesa 17.0.7

On another computer (two video cards):
Graphics:  Card-1: Intel Sky Lake Integrated Graphics
           Card-2: NVIDIA GM108M [GeForce 940MX]
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.0.7

Graphics:  Card-1: Intel Sky Lake Integrated Graphics
           Card-2: NVIDIA GM108M [GeForce 940MX]
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1920x1080@60.05hz, 1920x1080@60.00hz
           GLX Renderer: GeForce 940MX/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.98

All of them produce the bug with Linux Mint 17.3 Mate 1.18.

Let me know if any other info is needed.
Comment 14 krajcsi 2017-11-03 18:09:17 UTC
(In reply to krajcsi from comment #13)
> On one of my computers:
> Graphics:  Card: Intel Device 5916
>            Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
>            Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
>            GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2)
>            GLX Version: 3.0 Mesa 17.0.7
> 
> On another computer (two video cards):
> Graphics:  Card-1: Intel Sky Lake Integrated Graphics
>            Card-2: NVIDIA GM108M [GeForce 940MX]
>            Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
>            Resolution: 1600x900@60.00hz, 1920x1080@60.00hz
>            GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
>            GLX Version: 3.0 Mesa 17.0.7
> 
> Graphics:  Card-1: Intel Sky Lake Integrated Graphics
>            Card-2: NVIDIA GM108M [GeForce 940MX]
>            Display Server: X.Org 1.18.4 driver: nvidia
>            Resolution: 1920x1080@60.05hz, 1920x1080@60.00hz
>            GLX Renderer: GeForce 940MX/PCIe/SSE2
>            GLX Version: 4.5.0 NVIDIA 384.98
> 
> All of them produce the bug with Linux Mint 17.3 Mate 1.18.
> 
> Let me know if any other info is needed.

Sorry, it's Linux Mint 18.2, not 17.3.
Comment 15 Yousuf Philips (jay) (retired) 2017-11-05 15:59:14 UTC
I can confirm the issue and it doesn't happen with the Compiz window manager and does with the Marco, Marco + Software Compositor, and Marco + Compton window managers on Mate and the Xfwm window manager with or without compositing.

Tested on Linux Mint 18 Mate, Linux Mint 18.2 Xfce, Solus 3 Mate.
Comment 16 Yousuf Philips (jay) (retired) 2017-11-05 16:00:21 UTC
With XFCE, when you initially jump into fullscreen mode, the document area isnt drawn as well.
Comment 17 krajcsi 2017-11-06 10:06:07 UTC
I double checked the bug with Compiz, and I can confirm that switching to another workplace and switching back works fine.

Maybe a related issue is that sometimes (not always, I'd say approximately 50% of the time) when switching to full screen, the document is not visible, but the same grey area can be seen, as in the workplace switching bug. In other cases switching to full screen works fine.

Version: 5.4.2.2
Build ID: 1:5.4.2~rc2-0ubuntu0.16.04.1~lo2
CPU threads: 4; OS: Linux 4.11; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

Linux Mint 18.2, MATE 1.18.0
Comment 18 krajcsi 2018-02-13 16:33:43 UTC
With the new LO version the issue seems to be solved.

Version: 6.0.1.1
Build ID: 1:6.0.1~rc1-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

Linux Mint 18.3, MATE 1.18.0, Marco+Compositing
Comment 19 Buovjaga 2018-02-13 19:15:08 UTC
Great, let's close.