Download it now!
Bug 112355 - libre Office writer crashes when saving as docx file
Summary: libre Office writer crashes when saving as docx file
Status: RESOLVED DUPLICATE of bug 112169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2017-09-12 16:28 UTC by Gus Mai
Modified: 2017-09-13 17:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Resume file crashes when saving as docx (26.48 KB, application/vnd.oasis.opendocument.text)
2017-09-12 16:28 UTC, Gus Mai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gus Mai 2017-09-12 16:28:04 UTC
Created attachment 136206 [details]
Resume file crashes when saving as docx

When save as: This document may contain formatting or content that cannot be saved in the currently selected file format “Microsoft Word 2007-2013 XML”.

When choose "Use Microsoft Word 2007-2013 XML format" it goes to LibreOffice Document Recovery window. The recovery of the document in odt format was successful, but when save as docx it goes to the cycle: document recovery, recovery successfully, but a docx was never created successfully.
Comment 1 Dieter 2017-09-12 19:18:39 UTC
1. I opened the attachment (LO 5.3.6.1)
2. Save as docx => crash

So I can confirm the bug.
Comment 2 Julien Nabet 2017-09-12 20:07:52 UTC
On pc Debian x86-64 with LO Debian package 5.4.1, I could reproduce this.
But I don't reproduce with master sources updated today.
Comment 3 MM 2017-09-12 20:23:26 UTC
Dup of bug 112169 ?

Master, 5.4.2 & 5.3.7 got the patch, so thats why 5.4.1 might still crash.
Comment 4 Julien Nabet 2017-09-13 17:24:19 UTC
I confirm it's a dup.
Indeed, reverting the patch of tdf#112169 triggered a crash (more precisely an assert).
Don't hesitate to reopen this tracker if you still reproduce this next release 5.4.2 or with a recent daily build of 6.0

*** This bug has been marked as a duplicate of bug 112169 ***