Bug 112413 - RTF document with alternating portrait-landscape pages imports wrong
Summary: RTF document with alternating portrait-landscape pages imports wrong
Status: RESOLVED DUPLICATE of bug 82111
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf, preBibisect, regression
Depends on:
Blocks: RTF-Opening RTF-New-Import
  Show dependency treegraph
 
Reported: 2017-09-15 19:04 UTC by robert
Modified: 2022-01-27 10:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Alternating Portait-landscape document showing the bug (2.15 KB, application/rtf)
2017-09-15 19:04 UTC, robert
Details
PDF document of the result (25.70 KB, application/pdf)
2017-09-16 13:50 UTC, Dieter
Details
The example file in current master (157.26 KB, image/png)
2022-01-27 10:57 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robert 2017-09-15 19:04:20 UTC
Created attachment 136271 [details]
Alternating Portait-landscape document showing the bug

The attached Word .RTF document contains five pages in the order portait-landscape-portrait-landscape-landscape. It opens correctly in Word XP, but in Writer the first line of the last paragraph of the first three pages is directly followed by the first paragraph of the next page, leading also to the erroneous status line, when the document is scrolled down completely, of "Page 4 of 5", which in turn means that it actually knows that there are five pages...

Expected display, where '====' indicates a page break:

test
test
test
test
test
====
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
| Year | Trip | Ride |     KM |  Time |    V= | Type | Nat | Cty | Departure                                       | Arrival                                         |
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
| 1990 |   11 |   66 | 2502.9 | 22:41 | 110.3 | -    | NL  | *   | exit Platamonas                                 | Driebergen                                      |
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
====
test 2
test 2
test 2
test 2
test 2
====
Top-10 per trip
====
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
| Year | Trip | Ride |     KM |  Time |    V= | Type | Nat | Cty | Departure                                       | Arrival                                         |
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
| 1980 |    1 |   47 |  924.0 |  9:30 |  97.3 | -    | N   | *   | Varberg                                         | De Bilt                                         |
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+

actual display in Writer:

test
test
test
test
====
test+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
| Year | Trip | Ride |     KM |  Time |    V= | Type | Nat | Cty | Departure                                       | Arrival                                         |
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
| 1990 |   11 |   66 | 2502.9 | 22:41 | 110.3 | -    | NL  | *   | exit Platamonas                                 | Driebergen                                      |
====
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+test 2
test 2
test 2
test 2
====
test 2Top-10 per trip
====
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
| Year | Trip | Ride |     KM |  Time |    V= | Type | Nat | Cty | Departure                                       | Arrival                                         |
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+
| 1980 |    1 |   47 |  924.0 |  9:30 |  97.3 | -    | N   | *   | Varberg                                         | De Bilt                                         |
+------+------+------+--------+-------+-------+------+-----+-----+-------------------------------------------------+-------------------------------------------------+

This is a new file, created after the release of LO 5.4.1.2, I have no clue if it happened before.
Comment 1 Dieter 2017-09-16 13:49:42 UTC
I confirm it with LO 5.3.6.1. I opened the attachement and get the result as described.
Comment 2 Dieter 2017-09-16 13:50:45 UTC
Created attachment 136286 [details]
PDF document of the result
Comment 3 QA Administrators 2018-10-18 02:48:45 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2018-10-18 08:53:46 UTC
still repro in 

Version: 6.2.0.0.alpha0+
Build ID: d9ad59da50c1172fe98f94370221c9c1b688200a
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-08_23:34:44
Locale: ru-RU (ru_RU); Calc: threaded
Comment 5 QA Administrators 2019-10-19 02:42:49 UTC Comment hidden (obsolete)
Comment 6 robert 2019-10-19 08:52:05 UTC
Still present in

Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded
Comment 7 robert 2020-09-03 21:46:49 UTC
Still present:

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded
Comment 8 robert 2021-05-12 20:52:37 UTC
Still present @

Version: 7.1.3.2 (x64) / LibreOffice Community
Build ID: 47f78053abe362b9384784d31a6e56f8511eb1c1
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded
Comment 9 Aron Budea 2021-08-15 05:45:37 UTC
Fine in 3.4.0, buggy in 3.5.0 and in oldest of bibisect-43all.
Comment 10 Gabor Kelemen (allotropia) 2022-01-27 10:57:28 UTC
Created attachment 177827 [details]
The example file in current master

This seems to have been fixed in 7.3 since:

https://git.libreoffice.org/core/+/fce76110e02409b67ad977ae0077adf55ca58065

author	Justin Luth <justin_luth@sil.org>	Tue Jul 13 10:12:21 2021 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	Fri Jul 16 08:57:16 2021 +0200

tdf#82111 rtf import: ensure CR before section break
Comment 11 Gabor Kelemen (allotropia) 2022-01-27 10:57:59 UTC
Thanks Justin for fixing this one too!

*** This bug has been marked as a duplicate of bug 82111 ***