Download it now!
Bug 112431 - CalcA11y extremely Slow when opening a second Document
Summary: CalcA11y extremely Slow when opening a second Document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y
  Show dependency treegraph
 
Reported: 2017-09-16 17:48 UTC by am_dxer
Modified: 2018-01-29 13:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2017-09-16 17:48:07 UTC
Description:
When entering data into the second document in LibreOffice Calc, the program becomes very sluggish.

Steps to Reproduce:
1. Launch libreoffice and select Writer document or Calc document.
2. If selecting Calc document, moving between cells and entering data works fine and is responsive.
3. Select New Calc Document from the file menu.
4. When entering data, and then trying to move to another cell with the arrow keys in the second document, the program becomes very unresponsive.
5. If switching back to the first document, the program is responsive when performing step 4.
6. If switching again to the second document, the program becomes unresponsive when performing step 4.

Actual Results:  
The program became slow when editing the second document.

Expected Results:
The program should have been responsive as was the case in the first open document.


Reproducible: Always

User Profile Reset: Yes

Additional Info:
Version: 5.4.1.2.0+
Build ID: 1:5.4.1-1
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Xavier Van Wijmeersch 2017-09-17 08:38:54 UTC
can not confirm with

Version: 5.4.2.0.0+
Build ID: 61d85c4e7c30ea0f5242d927b7456190020b4fbe
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
build 13/09/2017
Comment 2 Alex ARNAUD 2017-09-18 12:44:27 UTC
Dear all,

I can't reproduce the issue on Debian 8.9 with LibreofficeDev 6.0.

@am_dxer: are you able to reproduce the issue on LibreofficeDev 6.0? If yes, could you give us spreadsheets documents and the exact steps to reproduce the issue?

Best regards.
Comment 3 Buovjaga 2017-10-28 15:14:40 UTC
(In reply to Alex ARNAUD from comment #2)
> @am_dxer: are you able to reproduce the issue on LibreofficeDev 6.0? If yes,
> could you give us spreadsheets documents and the exact steps to reproduce
> the issue?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists and you have attached the documents. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 4 am_dxer 2018-01-29 13:34:38 UTC
I tested this and  can't produce it in Version: 6.1.0.0.alpha0+
Build ID: 6a29d733651eb307ee8a6c3cf1bc64579070e53a
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 5 Alex ARNAUD 2018-01-29 13:39:22 UTC
Thanks for the additional information.

As am_dxer is not longer able to reproduce the issue I mark the issue as resolved WORKFORME.

Best regards.