Bug 112511 - Text pasted as unformatted, gets the insertion point style for all paragraphs.
Summary: Text pasted as unformatted, gets the insertion point style for all paragraphs.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 112510 112999 (view as bug list)
Depends on: Writer-Styles-Paragraph
Blocks: Paste-Special-Unformatted
  Show dependency treegraph
 
Reported: 2017-09-20 07:58 UTC by ggallozz
Modified: 2018-10-16 07:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ggallozz 2017-09-20 07:58:45 UTC
This happens since v 5.4.x has been released. Not in v. 4.x.

Let say you have copied a text with several paragraphs, and are going to paste it in a Writer document, no matter of which the insertion point paragraph style is (default text, heading1, quotation), all the pasted text paragraphs now get the style aforementioned; not even respecting the rules of the "following paragraph" for that style. 
So if you paste a text with one line paragraph, followed by several others, which one you would takes heading1 style, and the others get the rule of the "following paragraph" style (for heading1 style this should be default style), you'll get instead all heading1 style paragraphs.
Comment 1 Dieter 2017-09-20 08:54:45 UTC
*** Bug 112510 has been marked as a duplicate of this bug. ***
Comment 2 Étienne 2017-10-14 20:15:32 UTC
I confirm this problem with libreOffice 5.4.2.2
Comment 3 Dieter 2017-10-15 05:15:57 UTC
Changed to NEW because of comment 2.
Comment 4 Dieter 2017-10-15 05:18:41 UTC
*** Bug 112999 has been marked as a duplicate of this bug. ***
Comment 5 QA Administrators 2018-10-16 02:50:33 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2018-10-16 07:57:27 UTC
I do confirm the problem in

Version: 5.4.0.0.alpha1+
Build ID: 9feb7f7039a3b59974cbf266922177e961a52dd1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but no longer in

Versió: 6.1.2.1
ID de la construcció: 1:6.1.2~rc1-0ubuntu0.16.04.1
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded

Closing as RESOLVED WORKSFORME

I used attatchment 136852 from bug 112999 to test it