Bug 112522 - let the user select the fonts to embed
Summary: let the user select the fonts to embed
Status: RESOLVED DUPLICATE of bug 95062
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Embedded
  Show dependency treegraph
 
Reported: 2017-09-20 12:57 UTC by Callegar
Modified: 2021-03-24 12:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2017-09-20 12:57:16 UTC
Description:
Libreoffice has the ability to embed fonts in documents it saves in the opendocument format.

This could be a quite useful feature. However, its benefits are severely hindered by the choice LibO makes about the fonts to embed.

Currently, font embedding is on/off.

If embedding is activated all the fonts mentioned in the document are embedded, regardless if they are used or not. Specifically, all fonts that are used in the document or mentioned in the styles are embedded in all variants (normal, bold, italic, etc.).

This leads to huge files. For instance, on my system a writer document with no text at all is already at ~20MB. Same with an empty presentation.

Such big sizes implies that font embedding is unusable in many contexts, including some in which it would in fact be very convenient. For instance:

- Documents with embedded fonts are too large to be sent via email
- Presentations with embedded fonts exceed size for being uploaded at many conferences (one case where font embedding would otherwise be extra useful).

In addition to that the huge size makes the files with embedded fonts painfully slow to open. As an example, the above mentioned empty writer document takes more than 15 seconds to open on my workstation, with LibO already running and a warm cache.

The culprit for this problem is that LibO does not let the user select which fonts to embed, and ends up embedding "international" fonts which are usually very large.

1) It embeds fonts for Asian languages (which are typically very large) even if Asian language support is disabled. To me, this is a bug because with the Asian language support disabled LibO does not even let the user see/edit which Asian fonts are configured as part of the styles;

2) It embeds fonts for Complex layouts even if Complex layout is disabled. Again, to me this is a bug.

In my opinion, LibO should let the user select which fonts to embed. 

1) It should propose all fonts present in the document and let the user tick/untick one by one those to embed. The rationale for this is that the user may want to embed only some font that he knows would be hardly available by his/her collaborators.

2) It should provide an accelerator for selecting the embedding/not-embedding of all Asian fonts that are configured in styles but unused at once. The rationale for this is that: (i) an user may know from start that he will never use Asian fonts; (ii) another user, knowing that Asian fonts might be needed, may want to force their embedding even if his LibO currently has Asian font support disabled.

3) It should provide an accelerator for selecting the embedding/not embedding of all fonts for complex layouts that are unused but configured in styles at once. The rationale for this is that: (i) an user may know from start that he will never use complex layout fonts; (ii) another user, knowing that complex layout fonts might be needed, may want to force their embedding even if his LibO currently has complex layout support disabled.

4) It should provide an accelerator for selecting the embedding/not embedding of all fonts that are unused but configured in styles at once. The rationale for this is enabling the user to embed the minimal set of fonts needed for the display of the document (in particular of presentations).

Steps to Reproduce:
1. Create a new empty document.
2. Assure that no complex layout nor Asian text support is configured
3. Select font embedding
4. Save the document

Actual Results:  
The saved document is huge. All fonts mentioned in the document are embedded even those for Asian and complex layout.

Expected Results:
The fonts for Asian and/or complex layout should not be embedded because the support for Asian and complex languages is not active and the user in this situation is not even able to see via the style editor which fonts are configured for Asian and complex layout.

Note: This is midway between a bug and an enhancement request. The fact that fonts for Asian/Complex Layout are embedded even if their support is disable is a bug, IMHO. The solution I propose includes an enhancement request for the font embedding dialog.

Even better the font embedding dialog should propose a list of all fonts mentioned in the document letting the user tick/untick those to embed. Furthermore it should provide buttons to automatically tick/untick all Asian Fonts, all fonts for complex layout, all fonts that are mentioned in styles but unused in the document.


Reproducible: Always

User Profile Reset: No

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Builds ID: LibreOffice 5.4.2.1


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Jean-Baptiste Faure 2017-09-20 20:54:08 UTC
I agree with the idea that LO should be able to embed only used fonts and to allow the user to choose which font to embed.
That said I disagree with you on what you qualify as bug because Asian language support and complex layout are enabled / disabled at the user level (in user profile), AFAIK it is not a document property.

For me it is a valid enhancement request.

Best regards. JBF
Comment 2 tommy27 2017-10-05 09:22:13 UTC
enhancement request. 
status -> NEW
Comment 3 Timur 2021-03-24 12:39:47 UTC
Looks duplicate of older bug. 
Please be concise. Asian and Complex can be unchecked.

*** This bug has been marked as a duplicate of bug 95062 ***