Bug 112577 - CRASH: Crash when attempting to install an extension
Summary: CRASH: Crash when attempting to install an extension
Status: RESOLVED DUPLICATE of bug 44497
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2017-09-22 15:46 UTC by Telesto
Modified: 2017-10-03 18:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (6.96 KB, text/plain)
2017-09-22 23:18 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-09-22 15:46:56 UTC
Description:
CRASH: Crash when attempting to install an extension

Steps to Reproduce:
1. Download: https://extensions.libreoffice.org/extensions/copy-only-visible-cells/2.0/@@download/file/copyvisiblecells-2.0.oxt

2. Launch LibreOffice
3. Tools -> Extension Manger
4. Install 
5. Press add.
6. Select Copy Visible Cells
7. Press open -> Crash

Another way: download the extension and open it with LibODev

Actual Results:  
Crash

Expected Results:
No Crash


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: 4067487eb304c6686a22319c51790e41e311de08
CPU threads: 4; OS: Windows 6.29; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-09-21_05:02:40
Locale: nl-NL (nl_NL); Calc: CL

also a crash on MacOS


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xavier Van Wijmeersch 2017-09-22 17:02:41 UTC
Cannot reproduce with

Version: 6.0.0.0.alpha0+
Build ID: 54e608c6605ca2bcfd8dfdbe674d5110a18d2c5c
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 2 Xisco Faulí 2017-09-22 22:58:33 UTC
Confirmed in

Version: 6.0.0.0.alpha0+
Build ID: 46fa042b94a0364c09482e8a09f8874119db231c
CPU threads: 4; OS: Linux 4.10; UI render: GL; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Xisco Faulí 2017-09-22 23:00:46 UTC
Not reproduced in

Version: 6.0.0.0.alpha0+
Build ID: e808bbe1ce51465e6f3e9dc4fec2ecd263fe0e4b
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Julien Nabet 2017-09-22 23:18:01 UTC
Created attachment 136482 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today (a6b80833b0e8e2601fed7b9bc89ff79087edaf20), I could reproduce this.
Comment 5 Julien Nabet 2017-09-22 23:19:50 UTC
Jan-Marek: noticing solarmutex in bt, thought you might be interested in this one.
Comment 6 Xisco Faulí 2017-09-22 23:36:42 UTC
Regression introduced by:

author	Jan-Marek Glogowski <glogow@fbihome.de>	2017-08-15 06:05:51 (GMT)
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2017-09-19 07:25:14 (GMT)
commit	3840aede596e6fc24f7ed7df9100fb028134aac6 (patch)
tree	74d1d5efa3b2ad5448181fc185faf226aed192e4
parent	10b49dfb3996f99dec8dd0d2ffae2aef4022f395 (diff)
Unify SolarMutex implementations
All backends implement the SolarMutex in mostly the same way.
So this consolidates this code into a GenericSolarMutex.

We still need the abstract SolarMutex class for the fake AKA
fascade implementation in dbaccess.

The patch also replaces various places of direct mutex usage with
either SolarMutexGuard or SolarMutexReleaser objects.

Bisected with bibisect-linux64-6.0

Adding Cc: to Jan-Marek Glogowski
Comment 7 Telesto 2017-10-03 18:52:28 UTC

*** This bug has been marked as a duplicate of bug 44497 ***