Bug 112592 - FILESAVE: DOCX - Google Docs .docx crashes Writer when saving
Summary: FILESAVE: DOCX - Google Docs .docx crashes Writer when saving
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX Save
  Show dependency treegraph
 
Reported: 2017-09-23 16:10 UTC by advation
Modified: 2017-09-24 09:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Google Doc Downloaded Test.docx (4.24 KB, application/wps-office.docx)
2017-09-23 16:10 UTC, advation
Details

Note You need to log in before you can comment on or make changes to this bug.
Description advation 2017-09-23 16:10:07 UTC
Created attachment 136488 [details]
Google Doc Downloaded Test.docx

The follow steps can be used to replicate the problem with LibreOffice 5.4.1.2:

1. Create and download a docx from Google Docs
2. Open with LibreOffice Writer
3. Save the file as a .docx 

The above steps will result in Writer crashing then launching the document recovery process. 

I've tested this with multiple systems running Ubuntu 16.04.3 LTS. 

Attached file is an example .docx downloaded from Google Docs.
Comment 1 advation 2017-09-23 16:11:14 UTC
Please let me know if there are any logs I can submit to help identify the cause. 

Thanks!
Comment 2 raal 2017-09-23 16:41:48 UTC
No repro with Version: 6.0.0.0.alpha0+
Build ID: afeff9102c2935139de4efd40fd2286dce396706
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-17_23:32:41

Xisco wrote in the chat the bug was fixed. Closing.


http://dev-builds.libreoffice.org/daily/master/
Comment 3 Yousuf Philips (jay) (retired) 2017-09-23 19:49:14 UTC
The crash report.

http://crashreport.libreoffice.org/stats/crash_details/40b6aa82-833d-44e2-9324-45176fc4c020
Comment 4 Yousuf Philips (jay) (retired) 2017-09-24 09:24:33 UTC
Sorry advation but i didnt do step 3 when i tested and though LO crashed when you open the document. :D

So i tested 5.4.2 and 5.3.7 and it doesnt crash there, so you are good when the latest version comes out.

Version: 5.4.2.0.0+
Build ID: 61d85c4e7c30ea0f5242d927b7456190020b4fbe
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-4, Time: 2017-09-15_12:00:43
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.3.7.0.0+
Build ID: a562be54f3127f4e22a3a38e62db2b38d48499f3
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-3, Time: 2017-09-19_03:52:04
Locale: en-US (en_US.UTF-8); Calc: group