Bug 112615 - Customization dialog is too wide
Summary: Customization dialog is too wide
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2017-09-24 13:29 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-10-08 15:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
red 100px areas in both function lists (89.29 KB, image/png)
2017-09-24 13:29 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-09-24 13:29:48 UTC
Created attachment 136511 [details]
red 100px areas in both function lists

In 5.4, the customization dialog was 605x671, while the new version in 6.0 is 874x673, a width increase of 269px, when it could easily be reduced by 200+ pixels by reducing the minimum widths of the 2 function lists, which will reduce the large amount of white space in the dialog.
Comment 1 Xisco Faulí 2017-10-10 14:31:53 UTC
Regression introduced by:

author	Muhammet Kara <muhammet.kara@pardus.org.tr>	2017-09-11 12:42:30 (GMT)
committer	Heiko Tietze <tietze.heiko@googlemail.com>	2017-09-12 19:48:20 (GMT)
commit	e970395c692a5c315914ddf5b43cf01e590345ff (patch)
tree	7aa71acfbdbd6fd80b079d498d8f20374d29251b
parent	9659efe3f695aeeffc4cae427b80020fd2d96796 (diff)
tdf#112241: Improve column width behaviour in Customize dialog
Also:
 * Remove unnecessary frame "contents"
 * Remove unnecessary alignment
 * Remove extra column from the left grid (grid4)
 * Move all into a new grid for better sizing

Bisected with: bibisect-linux64-6.0

Adding Cc: to Muhammet Kara
Comment 2 Heiko Tietze 2017-10-15 07:07:48 UTC
Talked to Muhammet and the thing is that the dialog width is being calculated from the text in the list. Obviously not the best approach and he will turn this into a normal Glade accessible ui property.
Comment 3 Muhammet Kara 2018-10-08 14:04:28 UTC
It can be reduced to 800px easily. Would that be enough?
Comment 4 Muhammet Kara 2018-10-08 14:06:30 UTC
Forgot to mention how. Sorry for the noise.

Here is the relevant line: https://opengrok.libreoffice.org/xref/core/cui/source/customize/cfg.cxx#1152

One can achieve 800px width just by reducing the first number.
Comment 5 Heiko Tietze 2018-10-08 15:07:33 UTC
These few pixels are not visible unless you compare directly. And actually I disagree with the need to cut off all whitespace. The dialog is well designed and provides room for the various string length. Since no body agreed with Jay I close the ticket as WF.