Bug 112666 - NSAccessibility - accessibility failures when Starting Calc from StartCenter
Summary: NSAccessibility - accessibility failures when Starting Calc from StartCenter
Status: RESOLVED DUPLICATE of bug 112665
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2017-09-26 14:11 UTC by Alex Thurgood
Modified: 2020-09-21 14:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Apple accessibility audit report on starting Calc (6.45 MB, text/html)
2017-09-26 14:12 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2017-09-26 14:11:38 UTC
Description:
Description:
The enclosed report details the lack of, or incorrect accessibility feature implementation when starting a new Calc document from the StartCenter.

Steps to Reproduce:
1.Start LibreOfficeDev master
2. Start Accessibility Inspector (Xcode developer tool)
3. Attach Inspector to running LibreOfficeDev process
4. Click on StartCenter window.
5. Click on the New Calc Document button
5. Run Audit from Inspector tools


Actual Results:  
See enclosed output frm audit tool, exported as HTML file

Expected Results:
The application should correctly implement accessibility features in accordance with Apple guidelines.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Alex Thurgood 2017-09-26 14:12:37 UTC
Created attachment 136546 [details]
Apple accessibility audit report on starting Calc
Comment 2 QA Administrators 2018-10-10 03:05:15 UTC Comment hidden (obsolete)
Comment 3 Timur 2020-09-21 14:08:31 UTC
No need to have multiple reports.

*** This bug has been marked as a duplicate of bug 112665 ***