Download it now!
Bug 112686 - MAILMERGE : after "Edit Individual Documents" cannot "Send (merged) e-mail" with personalizations
Summary: MAILMERGE : after "Edit Individual Documents" cannot "Send (merged) e-mail" w...
Status: RESOLVED DUPLICATE of bug 98986
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2017-09-27 07:32 UTC by worms
Modified: 2017-12-29 15:41 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
merged document (9.61 KB, text/plain)
2017-12-22 13:27 UTC, worms
Details

Note You need to log in before you can comment on or make changes to this bug.
Description worms 2017-09-27 07:32:01 UTC
Since the libroffice version  with Mailmerge splitted in 2 parts, 
it's no more possible to edit an individual merged document before to save print or email 
you can choose several operations
"edit document", "save merged document", "print merged document", or "email "
if you edit individual document, you can save it, but you can't use the modified documents
when you run email print or save merged documents  , 
mail-merge function,  creates new merged documents , without taking in account modifications you have done with "edit individual document" function 

regards
Comment 1 Julien Nabet 2017-09-27 08:50:17 UTC Comment hidden (obsolete)
Comment 2 worms 2017-09-29 19:58:45 UTC Comment hidden (obsolete)
Comment 3 worms 2017-10-18 08:32:00 UTC Comment hidden (no-value)
Comment 4 Timur 2017-12-18 15:40:14 UTC Comment hidden (obsolete)
Comment 5 worms 2017-12-22 13:27:49 UTC Comment hidden (obsolete)
Comment 6 worms 2017-12-22 13:31:21 UTC
Comment on attachment 138597 [details]
merged document

before 5.3 version, it was possible to modify an individual merged document before to send it by mail, (in the attached document, the second one has been modified)
since 5.3 version, when you ask to send by mail, it run the creation of merged documents and automatically send results  by mail, 
so it's no more possible to modify
Comment 7 Timur 2017-12-22 14:07:44 UTC Comment hidden (obsolete)
Comment 8 worms 2017-12-22 19:18:59 UTC Comment hidden (obsolete)
Comment 9 Timur 2017-12-25 08:30:47 UTC Comment hidden (obsolete)
Comment 10 worms 2017-12-25 18:13:19 UTC Comment hidden (obsolete)
Comment 11 Timur 2017-12-26 11:25:25 UTC
You are persistent in replying and in not writing steps. I guess it's like this:

1. Use Mail Merge Wizard (or just Mail Merge toolbar from LO 5.3)
2. In step 2. "document type" select E-mail (optional)
3. After 5-step wizard is finished (or field is inserted from Mail Merge toolbar), press "Edit Individual Documents" on Mail Merge toolbar to personalize messages

Actual: new document is open so not obvious how to send e-mail messages
Expected: "return to Mail Merge" like up to LO 5.1
Solution: when new document is open with "Edit Individual Documents" it still has Mail Merge toolbar to proceed with "Send (merged) e-mail".

In 5.2. and on, there should be no need to "return to Mail Merge" because you can use Mail Merge toolbar.
So, when new document is open and personalization done, you need to turn on View-Mail Merge toolbar and then use "Send (merged) e-mail". If it works, problem is just showing Mail Merge toolbar.
Comment 12 worms 2017-12-26 13:35:05 UTC
Timur
you are right , I didn't describe step by step
problem is when you have the "mail merge" tool bar available

I have tried your solution , "Edit individual document"
in the new open document , I made modifications, then "view Merge Mail tool bar "
and click on "send by mail"
BUT this is not the solution because it send n time the same message to the n mail adresses

and not each page to each mail adress
Comment 13 Timur 2017-12-26 13:48:07 UTC
I'll put to New based on previous comment. I didn't test myself due to lack of available mail server. So I kindly ask others to test.
Comment 14 worms 2017-12-27 08:41:28 UTC
there is the same problem for 
save Merged documents (if you want to have individual files) or Print Merged Documents
it seems that it's an architecture problem, 
When the "mail merge" toolbar becomes available, merged documents are not yet created, they are created when you clik on one of the boutons of mail merge toolbar without possible manual modifications 

regards
Comment 15 Timur 2017-12-29 15:41:22 UTC

*** This bug has been marked as a duplicate of bug 98986 ***