Download it now!
Bug 112711 - "The Specified Device is Invalid" when attempting to access OneDrive
Summary: "The Specified Device is Invalid" when attempting to access OneDrive
Status: RESOLVED DUPLICATE of bug 62437
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CMIS
  Show dependency treegraph
 
Reported: 2017-09-28 04:08 UTC by John R Mead
Modified: 2017-12-17 08:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of LibreOffice dialogue box with error message (416.21 KB, image/png)
2017-09-28 04:08 UTC, John R Mead
Details
The whole process of asking for authorization for LibreOffice to access my OneDrive account (1.32 MB, application/x-zip-compressed)
2017-09-28 04:31 UTC, John R Mead
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John R Mead 2017-09-28 04:08:15 UTC
Created attachment 136574 [details]
Screenshot of LibreOffice dialogue box with error message

I'm attaching screenshots of all the relevant steps taken to gain access for LibreOfffice to my OneDrive account. As far as I can tell, I did everything correctly, and I've doubleckecked that I entered my password correctly. I do not find the error message especially enlightening.
Comment 1 John R Mead 2017-09-28 04:31:24 UTC
Created attachment 136575 [details]
The whole process of asking for authorization for LibreOffice to access my OneDrive account

Well, that was frustrating. I didn't know you could only attach one file as an attachment; I thought I had added five, but only had the last one entered appear. The .zip file has five screen shots. 1. LibreOffice presenting url to be copied to browser. 2. url copied to browser. 3. the url returned to the browser. 4. the code from the url pasted into the LibreOffice dialogue box. 5. LibreOffice saying "The Specified Device is Invalid".

As I previously stated, I have verified that I entered the correct account name and password.

This is very frustrating; I'm trying to use OneDrive to prevent loosing unique files to hard drive crashes or other fatal system failures, something I have had happen to me in the past. I suppose I could edit the copy held in the local OneDrive directory and rely upon it syncing properly, but since LibreOffice has this ability built into it, I would like to use it. Someday I might be needing to access someone elses OneDrive account.
Comment 2 Asix Jin 2017-11-27 16:34:26 UTC
I have the same problem using LibreOffice 5.4.3.2

Onedrive Integration isn't working at all. My user and pass are correct and I have tried pasting the whole URL and just in the code in the auth dialog. Has anyone fixed this or at least knows what's going on.
Comment 3 danimal 2017-12-15 23:00:38 UTC
Just would like to add a +1 for a solution to this.  I need to use LibreOffice with Onedrive and can't believe this is not working.  Why can't authentication be done with app passwords or something simple like that?  I have tried this 10000 times and each time it fails.  enter the code each time and it gives me the same error "The Specified Device is Invalid"


Version: 5.4.3.2 (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
Locale: en-US (en_US); Calc: group
Comment 4 raal 2017-12-17 08:44:41 UTC

*** This bug has been marked as a duplicate of bug 62437 ***