Bug 112716 - Oracle Java JDK9 not recognized by LibreOffice on OSX
Summary: Oracle Java JDK9 not recognized by LibreOffice on OSX
Status: RESOLVED DUPLICATE of bug 100501
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2017-09-28 10:36 UTC by Alex Thurgood
Modified: 2017-10-06 09:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2017-09-28 10:36:16 UTC
Description:
On MacOSX 10.12.6.

I have a working LibreOffice 5361 and 5412 which both recognize Oracle JDK8 (u131).
I downloaded Oracle Java JDK9 and installed it.

Neither LO 5361 nor LO 5412 find the newly installed JDK9, under LibreOffice-Preferences-Advanced.


My own daily master build (LOdev) finds JDK9 automatically.



Steps to Reproduce:
See above

Actual Results:  
Current release builds of LO do not automatically detect JDK9

Expected Results:
LO should always detect the currently installed most recent version of the JDK


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Alex Thurgood 2017-09-28 10:38:06 UTC
@Stephan : one for you ?
Comment 2 Alex Thurgood 2017-09-28 11:00:43 UTC
On this page :

http://www.oracle.com/technetwork/java/javase/downloads/index.html

it states that the JDK9 contains a complete JRE - unfortunately, this does not appear to be the case, at least from a cursory inspection of the app bundle's contents in the JavaVirtualMachine directory.

A separate JRE download is available, but again not recognized by LO after installation.
Comment 3 Alex Thurgood 2017-09-28 11:38:36 UTC Comment hidden (obsolete)
Comment 4 Alex Thurgood 2017-09-28 11:39:07 UTC
(In reply to Alex Thurgood from comment #3)
Please ignore the last comment - wrong bug...
Comment 5 V Stuart Foote 2017-09-28 15:08:29 UTC
Patches in for 5.4.2 and 5.3.7

https://bugs.documentfoundation.org/show_bug.cgi?id=100501#c8
Comment 6 Stephan Bergmann 2017-09-28 15:41:20 UTC

*** This bug has been marked as a duplicate of bug 100501 ***