Download it now!
Bug 112738 - Addition of toolbar similar to MS Language toolbar
Summary: Addition of toolbar similar to MS Language toolbar
Status: RESOLVED DUPLICATE of bug 71176
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Toolbars
  Show dependency treegraph
 
Reported: 2017-09-29 04:22 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-29 13:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
page 662 from word 2003 for dummies (289.17 KB, image/png)
2017-09-29 04:22 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-09-29 04:22:42 UTC
Created attachment 136601 [details]
page 662 from word 2003 for dummies

So a redditer requested[1] the addition of a toolbar similar to the language toolbar found in MS Office 2002/XP, which has speech recognition, text to speech, and handwriting recognition. MS Office 2003 provides speech recognition through  Tools > Speech, but the actual toolbar seems to be an OS level toolbar.

[1] https://www.reddit.com/r/linux/comments/72zm5a/we_are_the_document_foundation_and_the/dnmit8l/

----

Some links i stumbled on about it

Opening Language Toolbar in MS Office
http://www.assistivetechnology.vcu.edu/files/mt/2/Opening+Language+Bar+in+Microsoft+Office.pdf

Word 2003 for Dummies
https://books.google.ae/books?id=GUW1YZ2aH-0C&pg=PA662&lpg=PA662&dq=language+toolbar+word+2003&source=bl&ots=IqL6eqhPhF&sig=WNuIXqp1oaExnApTnPB2giWI3KE&hl=en&sa=X&redir_esc=y#v=onepage&q&f=false
Comment 1 Heiko Tietze 2017-09-29 07:32:11 UTC
The redditer asked for "... to add the Spanish character and with one click of the mouse on the toolbar inserted that Spanish character." My reply was about easy configuration and reworked special character dialog, what I believe he is interested in.

This type of language toolbar requires speech recognition that we not have and likely never will. To me it's clearly a third party extension.
Comment 2 V Stuart Foote 2017-09-29 13:44:31 UTC
The Reddit comment made no request for voice recognition, which _is_ provided via OS on Windows. Rather the request was functionally a duplicate of bug 71176 -- Key combinations to easily insert accented Latin characters, or bug 42437 for macOS Press and Hold. On Windows OS language bar allows OS toggle of input method to match one of several UI locales.  

Adding speech recognition is rather out of scope, though there is an a11y need as expressed in bug 85153

*** This bug has been marked as a duplicate of bug 71176 ***