Bug Hunting Session
Bug 112750 - Bulgarian hyphenation dictionary update
Summary: Bulgarian hyphenation dictionary update
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Hristo Simeonov Hristov
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-29 12:06 UTC by Stoyan Dimitrov [:stoyan]
Modified: 2017-10-16 11:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Update and recode the dictionary to UTF-8. (100.18 KB, patch)
2017-09-29 12:06 UTC, Stoyan Dimitrov [:stoyan]
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stoyan Dimitrov [:stoyan] 2017-09-29 12:06:43 UTC
Created attachment 136622 [details]
Update and recode the dictionary to UTF-8.

We've identified and fixed an issue with Bulgarian hyphenation dictionary. The issue was causing disappearance of large amount of hyphenation points for short words (5-7 characters) and insufficient amount of points in longer words. The patch additionally converts the dictionary to UTF-8 and updates patterns to reflect the later changes in language rules.
The patch is against the upstream version located at https://sourceforge.net/p/bgoffice/code/HEAD/tree/trunk/OOo-hyph-bg/
Comment 1 Xisco Faulí 2017-09-29 21:17:37 UTC
Hello Stoyan,
Thanks for providing the patch.
Since the issue is in the Bulgarian Dictionary extension, could you please send an email to radnev@gmail.com as he seems to be the responsible of the extension?
Comment 2 Stoyan Dimitrov [:stoyan] 2017-10-01 17:43:27 UTC
What is expected from Mr. Radnev? Where exactly this extension resides? I don't see it in the extensions site.
Comment 3 Hristo Simeonov Hristov 2017-10-01 21:00:05 UTC
I have created path for LO for this issue:
https://gerrit.libreoffice.org/#/c/43000/2
Comment 4 Stoyan Dimitrov [:stoyan] 2017-10-12 20:25:56 UTC
All of my past & future contributions to LibreOffice may be licensed under the WTFPL license and if needed transfered to MPLv2/LGPL3+ dual license. And I don't care about the credits.