Bug 112799 - A lack of multithreading when searching for (formatted) text.
Summary: A lack of multithreading when searching for (formatted) text.
Status: RESOLVED DUPLICATE of bug 100479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-01 14:30 UTC by ask4support
Modified: 2021-01-06 07:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A test file (21.54 KB, application/vnd.oasis.opendocument.text)
2017-10-01 14:31 UTC, ask4support
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ask4support 2017-10-01 14:30:55 UTC
Description:
Will LibreOffice ever support multithreading for searching (at least in Writer) and perhaps for filling huge ranges of cells? 

Steps to Reproduce:
Searching in Writer
0. Open the attached file
1. Press Ctrl + H
2. Click "Attributes..." 
3. Check "Underline"
4. Click "Other Options"
5. Check "Regular expressions"
6. Type ".*" into the search field
7. Press Find All

Pasting in Calc
1. Select entire column. 
2. Paste something. 

Actual Results:  
Single CPU core fully loaded and LibreOffice hung for some time. Once it was searching for many minutes before i killed it, I was unable to reproduce that long time again. 

Expected Results:
Multiple CPU cores used. 


Reproducible: Always

User Profile Reset: Yes

Additional Info:
I accidentally selected a whole column in Calc and pasted a number to all the cells in the column. I noticed that it also uses only one core. 

I ran LibreOffice 4.2.8.2 with the different home directory set, so that I could switch to English, I believe it's the same as running from a clear installation. 


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Comment 1 ask4support 2017-10-01 14:31:51 UTC
Created attachment 136666 [details]
A test file
Comment 2 Buovjaga 2017-11-02 14:50:43 UTC

*** This bug has been marked as a duplicate of bug 65046 ***
Comment 3 Aron Budea 2021-01-06 07:06:01 UTC
As a performance problem, this rather looks like a duplicate of bug 100479.

*** This bug has been marked as a duplicate of bug 100479 ***