Bug 112818 - UI: Better understandable name for command .uno:PreviewZoom
Summary: UI: Better understandable name for command .uno:PreviewZoom
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Preview
  Show dependency treegraph
 
Reported: 2017-10-02 10:52 UTC by Thomas Lendo
Modified: 2017-10-05 18:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Visible name of .uno:PreviewZoom in menu (top) and dialog title (bottom) (18.29 KB, image/png)
2017-10-02 10:52 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-10-02 10:52:29 UTC
Created attachment 136680 [details]
Visible name of .uno:PreviewZoom in menu (top) and dialog title (bottom)

I suggest to use a better understandable name for command .uno:PreviewZoom, especially for a easier search in the functions list of the Customize dialog and to be self-explanatory in menus, etc.

Now it's called "Preview Zoom" in the Customize dialog and so it's displayed in menus. The title of the dialog--which is opened by this command--is "Zoom & View Layout".

Suggested names for both title and visible command name:
* Preview: Zoom & View Layout
* Zoom & View Layout for Preview


In localizations it's the same problem:
* German command name: "Maßstab Seitenansicht"
* German dialog title: Maßstab & Ansichtslayout"
Comment 1 Yousuf Philips (jay) (retired) 2017-10-05 02:17:42 UTC
(In reply to Thomas Lendo from comment #0)
> I suggest to use a better understandable name for command .uno:PreviewZoom,
> especially for a easier search in the functions list of the Customize dialog
> and to be self-explanatory in menus, etc.

This uno command is a contextual function that opens up the View > Zoom > Zoom... dialog only when in print preview mode, so not sure what a suitable label would be for it. Maybe 'Zoom (Print Preview Mode)...'

> Suggested names for both title and visible command name:
> * Preview: Zoom & View Layout
> * Zoom & View Layout for Preview

We have many labels in the menu that dont have the exact label as the dialog it opens and that isnt a problem in my view, as long as it has the main keyword(s) in it. e.g. File > Templates > Manage Templates, Tools > Footnotes and Endnotes

Heiko, Stuart, Adolfo: Your thoughts.
Comment 2 Heiko Tietze 2017-10-05 06:56:52 UTC
View > Zoom > Zoom... works for me, the dialog title too. 'Preview Zoom' is by default located in the preview toolbar where its function is clear. Alternative name could be 'Zoom level' or just 'Zoom'. 

The customize dialog is targeting experts, ideally together with the offline help. In that case you get additional information below the list of commands, and it makes a lot of sense to show details there like 'This command shows a dropdown control with the current zoom level along a few other options usually in the print preview toolbar'.
Comment 3 Yousuf Philips (jay) (retired) 2017-10-05 16:19:27 UTC
Nice catch Heiko. The label 'Preview Zoom' is good, as its intended to let you know that the zoom level set in preview mode doesnt affect the zoom level when in regular mode.

So the problem is that this command should only be allowed to be added to the toolbar[1] according, but due to bug 112620 it is possible to add it to the menu bar.

[1] https://opengrok.libreoffice.org/xref/core/sw/sdi/swriter.sdi#4644