Bug 112821 - FILEOPEN: 2007 DOCX displays textbox with vertical absolute position below page (displayed in MS Word just in read-only mode or Web Layout)
Summary: FILEOPEN: 2007 DOCX displays textbox with vertical absolute position below pa...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: lowest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: OOXML-2007 VML-Shapes
  Show dependency treegraph
 
Reported: 2017-10-02 12:02 UTC by nagyt
Modified: 2020-11-26 15:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is the file rendered ugly in LibreOffice (158.53 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-10-02 12:02 UTC, nagyt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nagyt 2017-10-02 12:02:57 UTC
Created attachment 136685 [details]
This is the file rendered ugly in LibreOffice

An extra block is displayed in LibreOffice in a text document imported from MS Word DOCX format. The block hides a big portion of the document.
Comment 1 Xisco Faulí 2017-10-02 13:05:02 UTC
Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: a2a3e06a29077d4274dc15eea28a01afe22e3658
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Timur 2017-10-02 18:06:18 UTC
Looks like 2007 DOCX. Saved in MSO without compatibility doesn't display like that. I set to Lowest importance. 
It's a strange document with 2 textboxes, and this one is hidden. It's anchored to Telefonszám but with vertical absolute position 19,47 cm below Paragraph. 
Looks like user error to me.
Comment 3 QA Administrators 2018-10-03 02:53:51 UTC Comment hidden (obsolete)
Comment 4 nagyt 2018-10-03 14:23:03 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2019-10-04 03:05:46 UTC Comment hidden (obsolete)
Comment 6 nagyt 2019-10-04 08:59:23 UTC
The problem still exists

Verzió: 6.3.2.2
Build az.: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU szálak: 4; OS: Linux 4.18; Felületmegjelenítés: alapértelmezett; VCL: x11; 
Területi beállítások: hu-HU (hu_HU.UTF-8); Felület nyelve: hu-HU
Calc: threaded
Comment 7 NISZ LibreOffice Team 2020-11-26 14:47:57 UTC
Extra green textbox is no longer present in:

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

since:
https://git.libreoffice.org/core/+/195eae4852012eed6da72c0a9f55094a09aa2867

author
Miklos Vajna <vmiklos@collabora.com> Thu Jan 23 18:05:26 2020 +0100 
committer
Miklos Vajna <vmiklos@collabora.com> Thu Jan 23 22:22:56 2020 +0100 

sw DoNotCaptureDrawObjsOnPage: don't capture wrap-through Writer images, either

Rest of the document also looks good.

Thanks Miklos for fixing this one :)
Comment 8 Timur 2020-11-26 15:09:59 UTC
(In reply to Timur from comment #2)
> Saved in MSO without compatibility doesn't display like that.  
I should have attached MSO saved file, and that should be a practice in all bugs where original docx is older 2007. I can't do it now.